Recursive onblur/focus crashes browser

VERIFIED DUPLICATE of bug 71299

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 71299
18 years ago
17 years ago

People

(Reporter: Neil Fraser, Assigned: rogerl (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Any page with this as the body tag will crash Mozilla if you try to switch to
any other window:
  <BODY onBlur="window.focus()">
I'm using build 2001021503 for Linux, but we've confirmed that it also applies
to a recent Windows version of Mozilla, as well as NS4 and IE5.  Seems to be
similar to bug 25434, except that the latter bug claims to be fixed and only
appeared to apply to form elements, not browser windows.

A mallicous website could use a popup window to automatically invoke this bug
thus terminating your browser.
(Reporter)

Comment 1

18 years ago
Sorry, I submitted this twice.

*** This bug has been marked as a duplicate of 71299 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified Duplicate - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.