Last Comment Bug 713060 - Typing in URL bar on Droid Pro with hard keyboard always inserts at end
: Typing in URL bar on Droid Pro with hard keyboard always inserts at end
Status: RESOLVED FIXED
[HKB]
:
Product: Firefox for Android
Classification: Client Software
Component: Keyboards and IME (show other bugs)
: Trunk
: All Android
: P3 normal (vote)
: Firefox 14
Assigned To: Chris Peterson [:cpeterson]
:
: Jim Chen [:jchen] [:darchons]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 12:19 PST by away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2014-03-02 12:56 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
11+


Attachments

Description away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-12-22 12:19:32 PST
STR:

1. Start Fennec on the Droid Pro
2. Tap in the URL bar to give focus
3. Type some stuff (e.g. "fooooooooo")
4. Tap the screen in the middle of the typed stuff so that the caret moves to the middle of the typed text
5. Type another letter (e.g. "m")

Expected behaviour: letter gets inserted where the caret is
Observed behaviour: caret jumps to the end of the text field and appends the letter. With my above example, I get "fooooooooom" instead of "foooomooooo"

I'm using a recent build (https://hg.mozilla.org/mozilla-central/rev/c5b90ea7e475) so it should have the IME rewrite, I think.
Comment 1 Alex Pakhotin (:alexp) 2011-12-22 13:47:42 PST
Is this always reproducible? I don't see this issue in the latest nightly on my Droid Pro with Android 2.3.3.
What system version do you have, kats, and what IME is selected when you enter the text?

In any case it should not depend on my recent changes to our IME handling, as they were for the content edit fields, while AwesomeBar is a standard Android edit box.
Comment 2 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-12-22 14:03:10 PST
System Version is Version.3.8.7.XT610.Verizon.en.US, Android Version is 2.2.1. It seems to be 100% reproducible, happens every time I've tried. I'm not sure about the IME - there's no VKB or anything visible on screen when I put focus into the URL bar. I just type with the hardware keyboard. In the Language & Keyboard Settings, I have Input method = Multi-touch keyboard, Multi-touch keyboard = Onscreen keyboard settings, Device keyboard = built-in keyboard settings. I haven't touched these from when I got the device.
Comment 3 Alex Pakhotin (:alexp) 2011-12-22 14:12:36 PST
(In reply to Kartikaya Gupta (:kats) from comment #2)
> System Version is Version.3.8.7.XT610.Verizon.en.US, Android Version is
> 2.2.1. It seems to be 100% reproducible, happens every time I've tried.

Strange. Might be specific to Android 2.2, but I don't have that anymore - just updated the phone recently.

> I'm not sure about the IME - there's no VKB or anything visible on screen when
> I put focus into the URL bar. I just type with the hardware keyboard. In the
> Language & Keyboard Settings, I have Input method = Multi-touch keyboard,

Yes, this is what I wanted to confirm to see if it's different from my device.
For example, we had some input issues with SwiftKey X even though hardware keyboard was used. But again - that was with edit fields in the content, not in the AwesomeBar.

Do you see this issue with the nightly as well? Did it happen before?
Comment 4 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-12-23 05:48:07 PST
Yeah, I downloaded the latest nightly and am seeing it with that as well. I don't recall it happening before, but to be honest I don't remember trying this exact thing before.

I remember filing bug 704156 but that is different, and that remains fixed now. That is, if I *select* any of the text and type, the observed behaviour is fine, the typed text will get inserted in the right spot. However, if I just move the cursor to the middle of the text *without* selecting anything, then typing will move the cursor back to the end. If you want I can provide logcats or run a special build with more debug info if you need it.
Comment 5 Alex Pakhotin (:alexp) 2012-01-09 18:19:39 PST
I am unable to reproduce this on my Droid Pro with Android 2.3.3.
kats, do you still face this bug?
Naoki, can you reproduce this on your Droid Pro with 2.3?
Anyone has Droid Pro with Android 2.2 to confirm?
Comment 6 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-10 06:50:46 PST
Yup, it's still happening on the latest nightly. If you have logging/patches you want me to try let me know.
Comment 7 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-10 10:46:31 PST
It's reproducible on 2.2 and something I noticed when I first got the Droid Pro (which was on 2.2) and one of the reasons I had figured out how to upgraded to 2.3.  I can't reproduce the problem on Droid Pro 2.3.

Personally, I think it's an Android OS problem with the Droid pro.  I could be mistaken.  I would also think that anyone with the Droid Pro would upgrade to 2.3 due to other issues with the device on 2.2.  Default browser is a lot slower for one.  I can't recall all of the other problems I had on 2.2

I don't think it's also an unreasonable request to have the end user upgrade to 2.3
Comment 8 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-10 11:02:41 PST
That's fair. If it's only on Droid Pro 2.2 then I don't really care if it goes unfixed. I probably won't upgrade my device though since it's probably a good idea to keep at least one still running 2.2 in case other issues come up.
Comment 9 Chris Peterson [:cpeterson] 2012-03-20 15:16:03 PDT
Android 2.2 (Froyo) is supposed to be a supported version.

I see different misbehavior on my Droid Pro 2.2. When I try to insert text into the middle of a URL string, the new text overwrites the entire URL string.
Comment 10 Chris Peterson [:cpeterson] 2012-06-13 14:11:56 PDT
This bug has been fixed in Fennec 14.

Note You need to log in before you can comment on or make changes to this bug.