Firefox 9 or 9.0.1 is very very slow in javascript test (sunspider), > 7 times.

RESOLVED DUPLICATE of bug 713063

Status

()

RESOLVED DUPLICATE of bug 713063
7 years ago
7 years ago

People

(Reporter: fnitram, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

http://www.webkit.org/perf/sunspider/sunspider.html, click on link : "Start SunSpider 0.9.1 now!"

Firefox 9 or 9.0.1 run sunspider (javascript test) more than 7 times slower than firefox 8 or 8.0.1

Window XP up to date
AMD 32 bits CPU
I have disabled all modules or extensions


Actual results:

Sunspider is incredible slow. More than 7 times slower than previous branch (8)

Firefox 8 is about 1080 ms (total)

Look Firefox 9 :

============================================
RESULTS (means and 95% confidence intervals)
--------------------------------------------
Total:                  7632.1ms +/- 3.7%
--------------------------------------------

  3d:                   1123.0ms +/- 1.1%
    cube:                335.3ms +/- 3.6%
    morph:               372.2ms +/- 0.7%
    raytrace:            415.5ms +/- 1.8%

  access:               1671.5ms +/- 0.5%
    binary-trees:        185.5ms +/- 1.3%
    fannkuch:            799.9ms +/- 0.5%
    nbody:               427.1ms +/- 0.7%
    nsieve:              259.0ms +/- 0.7%

  bitops:               1589.4ms +/- 12.3%
    3bit-bits-in-byte:   209.8ms +/- 0.6%
    bits-in-byte:        299.3ms +/- 0.5%
    bitwise-and:         653.8ms +/- 16.8%
    nsieve-bits:         426.5ms +/- 20.1%

  controlflow:           261.4ms +/- 28.7%
    recursive:           261.4ms +/- 28.7%

  crypto:                663.4ms +/- 1.9%
    aes:                 303.6ms +/- 4.7%
    md5:                 176.6ms +/- 0.7%
    sha1:                183.2ms +/- 1.4%

  date:                  409.0ms +/- 1.9%
    format-tofte:        247.2ms +/- 0.8%
    format-xparb:        161.8ms +/- 4.1%

  math:                  970.4ms +/- 1.4%
    cordic:              393.6ms +/- 0.9%
    partial-sums:        316.4ms +/- 3.2%
    spectral-norm:       260.4ms +/- 1.1%

  regexp:                 29.7ms +/- 1.6%
    dna:                  29.7ms +/- 1.6%

  string:                914.3ms +/- 1.9%
    base64:              178.9ms +/- 1.9%
    fasta:               303.6ms +/- 0.9%
    tagcloud:            171.2ms +/- 9.5%
    unpack-code:         117.5ms +/- 1.0%
    validate-input:      143.1ms +/- 3.2%


Expected results:

Remember : the improve perf about 20% in javascript... so if firefox 8 is about 1080ms, firefox 9 should be about 800ms...

Good luck guys :)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713063
You need to log in before you can comment on or make changes to this bug.