Required system NSPR version should be bumped

RESOLVED DUPLICATE of bug 713229

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 713229
7 years ago
4 months ago

People

(Reporter: mounir, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently, the required nspr version is 4.8.8. I have 4.8.9 but I had a build failure caused by nspr:
/home/volkmar/projects/mozilla/gecko/dom/indexedDB/Key.cpp:411:57: error: ‘PR_UINT64’ was not declared in this scope

Indeed, PR_UINT64 is in prtypes.h in the tree but not in my system nspr's prtypes.h. I believe it is going to be added in 4.9 (it seems that the current version in the tree is 4.9beta5).

We should bump system nspr required version to something that is going to build.
Duplicate of this bug: 713229
There's a patch in the other bug already, let's duplicate the other way around.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713229

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.