Bad Flash content causing long browser hang and high ram usage.

RESOLVED INCOMPLETE

Status

()

Core
Plug-ins
--
major
RESOLVED INCOMPLETE
6 years ago
2 years ago

People

(Reporter: Priit Uring, Unassigned)

Tracking

(Blocks: 1 bug, {perf})

12 Branch
x86
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20111222 Firefox/12.0a1
Build ID: 20111222031055

Steps to reproduce:

Went to a Flash based website which I found on Google search http://issuu.com/expert_estonia/docs/expert_vabariik_a4_4lk_288000


Actual results:

It caused my browser and even IE9 to hang while staying entirely unresponsive for over 10min+ and raise ram usage slowly higher and higher.


Expected results:

Badly coded Flash content shouldn't cause entire browser to hang or use 3gb+ ram and constant 50% CPU usage(Athlon ll 240 x2 2.8ghz)
(Reporter)

Updated

6 years ago
Severity: normal → major
OS: Windows 7 → All
Priority: -- → P5
Hardware: x86 → All
Summary: Flash content causing long browser hang → Bad Flash content causing long browser hang and high ram usage.
(Reporter)

Comment 1

6 years ago
When HWA is turned off it loads 3 Thumbnails fine which aren't loaded at all if HWA is turned on (ATI 5450 dx11). Got 2 responses on Forum that  it loaded fine after short wait and 2gb ram usage.
(Reporter)

Updated

6 years ago
Keywords: hang
(Reporter)

Updated

6 years ago
Crash Signature: hang | npswf64_11_2_202_160.dll@0x108074
(Reporter)

Comment 2

6 years ago
Seems I can still crash plugin-container or restart browser and make browser unresponsive, or try reload. Might be easier to reproduce with slow connection. ATM I have no HWA and using Win7 32bit with 32bit Flash 11.2 beta4
(Reporter)

Updated

6 years ago
Depends on: 720000

Comment 3

5 years ago
Can you still reproduce this? If so, can you give us a current report ID?
Flags: needinfo?(prixsel)
(Reporter)

Comment 4

5 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> Can you still reproduce this? If so, can you give us a current report ID?

This hang, stall doesn't crash the browser only consumes a lot of CPU and RAM resources. When I posted the report then it consumed all ram rapidly, with current new Flash it is different behavior - I could try with 64bit one again or just old Flashplayer if necessary.

My current system: AMD Turion Mobile X2 1.9ghz; 2gb RAM; 32bit Win8; Nightly version 20 - 26th Dec & Flash 11.5.502.135

Opening Page or clicking on pictures arrow to read next page stalls Nightly for 10 seconds & then it starts working again <- looking in Process Explorer I see that Flash Plugin is using 49% of CPU.
Flags: needinfo?(prixsel)
(Reporter)

Updated

5 years ago
OS: All → Windows 8
Hardware: All → x86
(Reporter)

Updated

5 years ago
Crash Signature: hang | npswf64_11_2_202_160.dll@0x108074 → [@ F1398665248_____________________________ ]

Updated

5 years ago
Component: General → Plug-ins
Product: Firefox → Core

Comment 7

4 years ago
my browser hangs when searching from Google or when on pages that contain YouTube flash video content. It only occurs with Firefox. i did not get similar results when using Google or YouTube in current version of IE

HP s5759z
AMD Athlon IIx4 640 360GHz
64-bit, 4GB RAM
Windows 7 Home Premium SP1

Comment 9

4 years ago
Close FF with a tab with this url
https://accounts.google.com/ServiceLogin?passive=true&hl=it&uilel=3&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dredirect_login%26hl%3Dit%26next%3D%252Ffeed%252Fsubscriptions%252F&service=youtube

resteart ff with session restore.
why this url causes FF to freezen 10 seconds on startup?

its a very complex url?
thanks for verifying.

Comment 10

4 years ago
Duplicating per the crash signature.

Please correct me if I am wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 774281

Comment 11

4 years ago
how about the url? FF -due to the YT request- is trying to login login login, therefore the freeze with this irl.

Comment 12

4 years ago
alex, it doesn't make sense to dup specific bugs against bug 774281: that bug is a generic signature-tracking bug and we specifically want people who have specific STR to file a separate bug like this one.

That said, a bunch of people have piled on with their own *different* steps to reproduce, so I'm not really sure whether there is a specific bug here.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 13

4 years ago
Perhaps the website mentioned in OP is just slow?  It takes many seconds to slow some of the pages and for periods it goes unresponsive. And on http://issuu.com/huffington/docs/054_huffington_062313_book for example I got one "unresponsive plugin" dialog, but clicked continue and in a couple seconds I had the page
Flags: needinfo?(antoine.mechelynck)
Keywords: hang → perf
Priority: P5 → --
(In reply to Wayne Mery (:wsmwk) from comment #13)
> Perhaps the website mentioned in OP is just slow?  It takes many seconds to
> slow some of the pages and for periods it goes unresponsive. And on
> http://issuu.com/huffington/docs/054_huffington_062313_book for example I
> got one "unresponsive plugin" dialog, but clicked continue and in a couple
> seconds I had the page

Unresponsiveness during more than ten minutes with constantly increasing RAM sounds more than "just slow" to me; but since it happens also in IE it could be a bug in the design of the remote Flash object. If this is the case, this bug would belong in the "Tech Evangelism" product.

But that was the case when this bug was reported, in 2011 (see comment #0) and apparently with a Firefox 12 compiled for W64. Prixsel, which browser are you using now? (if using the User Agent Switcher extension or similar, please first tell it to go back to the default, then [in all cases] paste the lines "User agent" if present and "Build identifier" if present, from the bottom of the page which comes up when you type "about:" without the quotes in the Location bar then hit Enter)? And does it still hang for 10 minutes or more?

In SeaMonkey which I use, the equivalent to the lines I'm asking you to copy-paste look like this:

User agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 SeaMonkey/2.27a1
Build identifier: 20140214003001

In Firefox it will be slightly different (but with a "family resemblance") and part of it may be absent. Use copy and paste, not look and type. ;-)
Flags: needinfo?(antoine.mechelynck) → needinfo?(prixsel)

Comment 16

2 years ago
Is this till an issue ?  I do not see that much hang or RAM usage as mentioned by the reporter.

--
Version 	50.0a1
Build ID 	20160616030228
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Comment 17

2 years ago
(In reply to Abe - QA from comment #16)
> Is this till an issue ?  I do not see that much hang or RAM usage as
> mentioned by the reporter.

Which exact steps did you perform for testing? How much RAM usage do you see? Which Flash plugin version did you test this with, on which platform?
Flags: needinfo?(amasresha)

Comment 18

2 years ago
Created attachment 8763135 [details]
about-performance 2016-06-16 11-55-41.png

Steps given by the reporter are used. About:performance page is attached here.
URL used: http://issuu.com/expert_estonia/docs/expert_vabariik_a4_4lk_288000

Comment 19

2 years ago
Created attachment 8763136 [details]
about-plugins.png

Comment 20

2 years ago
Created attachment 8763137 [details]
About Plugins 2016-06-16 11-53-56.png

My bad, previous attachment is incorrect, it is about:support. About:plugin is attached now.

Updated

2 years ago
Flags: needinfo?(amasresha)

Comment 21

2 years ago
This is clearly a bug in the Flash player. It's an unfortunate fact that the Flash player can jank web content (and the entire browser without e10s), and there's not a lot we can do about that currently. I'm going to resolve this.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago2 years ago
Flags: needinfo?(pr11t)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.