Last Comment Bug 713232 - Built in Profiler hangs the browser on Windows
: Built in Profiler hangs the browser on Windows
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on:
Blocks: 713227
  Show dependency treegraph
 
Reported: 2011-12-23 07:56 PST by Benoit Girard (:BenWa)
Modified: 2011-12-24 22:16 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (4.54 KB, patch)
2011-12-23 11:40 PST, :Ehsan Akhgari
bgirard: review+
Details | Diff | Splinter Review

Description Benoit Girard (:BenWa) 2011-12-23 07:56:07 PST
STR:
1) Run nightly
2) Install the addon: https://builder.addons.mozilla.org/addon/1023834/latest/
3) User the browser and dump some profiles.

The browser should hang shortly after.
Comment 1 :Ehsan Akhgari 2011-12-23 11:40:44 PST
Created attachment 584095 [details] [diff] [review]
Patch (v1)

So the reason that this happens is that TimeStamp::Now() tries to hold a critical section, and if the mainthread has already acquired that lock and is currently paused, a deadlock occurs.

A simple fix is to grab the timestamp before pausing the main thread.
Comment 3 Phil Ringnalda (:philor) 2011-12-24 22:16:19 PST
https://hg.mozilla.org/mozilla-central/rev/45206fca898d

Note You need to log in before you can comment on or make changes to this bug.