If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Give access to dkl@mozilla.com and LpSolit@gmail.com to the FTP server to upload new Bugzilla tarballs

RESOLVED FIXED

Status

mozilla.org
FTP: Staging
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Frédéric Buclin, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
dkl is the new release manager for the Bugzilla project and so needs to be able to upload new tarballs to ftp://ftp.mozilla.org/pub/mozilla.org/webtools/. As the assistant project lead, I would also need such privileges to help dkl with releases if necessary.

We both already have SSH keys uploaded as we have commit access to bzr.
(Reporter)

Updated

6 years ago
Summary: Give access to dkl@mozilla.org and LpSolit@gmail.com to the FTP server to upload new Bugzilla tarballs → Give access to dkl@mozilla.com and LpSolit@gmail.com to the FTP server to upload new Bugzilla tarballs
I'll vouch for both.  LpSolit is our QA manager and probably should have had this for a few years for backup to the release manager anyway.  dkl is taking on release duties.

Should be set up with local user accounts on surf which match uid/gid with their existing LDAP POSIX accounts (you can get their ssh keys out of the LDAP accounts as well), and be locally placed in the bugzilla group on surf.
Sorry, the group name is webtools, not bugzilla.
(Reporter)

Comment 3

6 years ago
Any progress? We are mostly ready with the release stuff.

Comment 4

6 years ago
I've created these users on the 'surf' server with UIDs that match LDAP.  I've also added their keys to $HOME/.ssh/authorized_keys, so they should be able to access it.

At this point I'm not sure which directory they should be uploading to to distribute the files over FTP however.
(Reporter)

Comment 5

6 years ago
(In reply to Ben Kero [:bkero] from comment #4)
> At this point I'm not sure which directory they should be uploading to to
> distribute the files over FTP however.

webtools/ and webtools/archived/
I am still not able to login to stage.mozilla.org which is supposedly where we need to be able to upload bugzilla.org related files.

[dkl@localhost bz-release]$ ssh dlawrence@stage.mozilla.org
Permission denied (publickey).

Is the proper key installed? Am I trying the wrong server? wrong id?

thanks
dkl
(Reporter)

Comment 7

6 years ago
Same error message for me.
(Reporter)

Comment 8

6 years ago
The problem is now fixed. Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
for the record, the user accounts defaulted to locked when created.  Had to set the password field to '*' in /etc/shadow to allow them to log in with a key.
(In reply to Frédéric Buclin from comment #8)
> The problem is now fixed. Thanks!

works for me now too

thanks!
You need to log in before you can comment on or make changes to this bug.