Closed Bug 713401 Opened 8 years ago Closed 7 years ago

Intermittent test_service_passwordUTF8.js | false == true - See following stack:

Categories

(Firefox :: Sync, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=8146808&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test xpcshell on 2011-12-24 11:36:51 PST for push c93d8c55f67d

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_service_passwordUTF8.js | [run_test : 74] foobar == foobar
Make the server password the low byte version of our password.  Login should work and have transparently changed the password to the UTF8 version.
Sync.Resource	DEBUG	mesg: GET fail 401 http://localhost:8080/1.1/johndoe/info/collections
Sync.Resource	DEBUG	GET fail 401 http://localhost:8080/1.1/johndoe/info/collections
Sync.Service	WARN	401: login failed.
Sync.Resource	DEBUG	mesg: GET success 200 http://localhost:8080/1.1/johndoe/info/collections
Sync.Resource	DEBUG	GET success 200 http://localhost:8080/1.1/johndoe/info/collections
Sync.Service	DEBUG	Non-ASCII password detected. Changing to UTF-8 version.
Sync.Resource	DEBUG	POST Length: 12
Sync.Resource	DEBUG	mesg: POST success 200 http://localhost:8080/user/1.0/johndoe/password
Sync.Resource	DEBUG	POST success 200 http://localhost:8080/user/1.0/johndoe/password
Sync.Resource	DEBUG	mesg: GET success 200 http://localhost:8080/1.1/johndoe/info/collections
Sync.Resource	DEBUG	GET success 200 http://localhost:8080/1.1/johndoe/info/collections
Sync.Service	DEBUG	Fetching global metadata record
Sync.Resource	DEBUG	mesg: GET fail 404 http://localhost:8080/1.1/johndoe/storage/meta/global
Sync.Resource	DEBUG	GET fail 404 http://localhost:8080/1.1/johndoe/storage/meta/global
Sync.Service	DEBUG	Weave Version: 1.15.0 Local Storage: 5 Remote Storage: 
Sync.Service	INFO	One of: no meta, no meta storageVersion, or no meta syncID. Fresh start needed.
Sync.Service	INFO	No metadata record, server wipe needed
Sync.Service	INFO	Wiping server data
Sync.Service	INFO	Fresh start. Resetting client and considering key upgrade.
Sync.Service	INFO	Service reset.
Sync.Engine.Clients	DEBUG	Resetting clients last sync time
Sync.Engine.Bookmarks	DEBUG	Resetting bookmarks last sync time
Sync.Engine.Forms	DEBUG	Resetting forms last sync time
Sync.Engine.History	DEBUG	Resetting history last sync time
Sync.Engine.Passwords	DEBUG	Resetting passwords last sync time
Sync.Engine.Prefs	DEBUG	Resetting prefs last sync time
Sync.Engine.Tabs	DEBUG	Resetting tabs last sync time
Sync.Engine.Addons	DEBUG	Resetting addons last sync time
Sync.CollectionKeys	INFO	Clearing CollectionKeys...
Sync.Service	INFO	Upgrading sync key...
Sync.Service	INFO	Saving upgraded sync key...
Sync.Service	INFO	Done saving.
Sync.Resource	WARN	Caught unexpected exception channel.URI is undefined JS Stack trace: _onComplete(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@resource.js:334 < innerBind(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@util.js:1071 < Channel_onStopRequest([object XPCWrappedNative_NoHelper],null,0)@resource.js:563 in _onComplete.
Sync.Resource	DEBUG	JS Stack trace: _onComplete(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@resource.js:334 < innerBind(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@util.js:1071 < Channel_onStopRequest([object XPCWrappedNative_NoHelper],null,0)@resource.js:563
Sync.Resource	DEBUG	Caught exception channel.visitResponseHeaders is not a function JS Stack trace: _onComplete(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@resource.js:361 < innerBind(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@util.js:1071 < Channel_onStopRequest([object XPCWrappedNative_NoHelper],null,0)@resource.js:563 visiting headers in _onComplete.
Sync.Resource	DEBUG	JS Stack trace: _onComplete(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@resource.js:361 < innerBind(null,"<html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html>",[object XPCWrappedNative_NoHelper])@util.js:1071 < Channel_onStopRequest([object XPCWrappedNative_NoHelper],null,0)@resource.js:563
Sync.Service	DEBUG	Aborting wipeServer. Server responded with undefined response for http://localhost:8080/1.1/johndoe/storage/
Sync.Service	DEBUG	verifyLogin failed: <html>                    <head><title>404 Not Found</title></head>                    <body>                      <h1>404 Not Found</h1>                      <p>                        <span style='font-family: monospace;'>&#47;&#49;&#46;&#49;&#47;&#106;&#111;&#104;&#110;&#100;&#111;&#101;&#47;&#115;&#116;&#111;&#114;&#97;&#103;&#101;</span> was not found.                      </p>                    </body>                  </html> No traceback available
Sync.Status	DEBUG	Status.login: error.login.reason.account => error.login.reason.network
Sync.Status	DEBUG	Status.service: error.login.failed => error.login.failed

TEST-UNEXPECTED-FAIL | c:/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_service_passwordUTF8.js | false == true - See following stack:
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_throw :: line 453
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _do_check_eq :: line 547
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_eq :: line 568
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_true :: line 582
JS frame :: c:/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_service_passwordUTF8.js :: run_test :: line 78
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _execute_test :: line 326
JS frame :: -e :: <TOP_LEVEL> :: line 1

TEST-INFO | (xpcshell/head.js) | exiting test

TEST-INFO | (xpcshell/head.js) | test 2 finished
Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
I rewrote this code in March. No oranges starred recently, so I think this has fixed itself.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.