Last Comment Bug 713408 - Don't clutter log with history entries in Profile Migrator
: Don't clutter log with history entries in Profile Migrator
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: Firefox 12
Assigned To: Gian-Carlo Pascutto [:gcp]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-24 14:35 PST by Philipp von Weitershausen [:philikon]
Modified: 2012-01-09 18:22 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
logcat (5.85 KB, text/plain)
2011-12-24 14:35 PST, Philipp von Weitershausen [:philikon]
no flags Details
full logcat (cleaned up) (102.75 KB, text/plain)
2011-12-27 03:36 PST, Philipp von Weitershausen [:philikon]
no flags Details
Patch 1. Reduce logging for Profile Migrator (5.50 KB, patch)
2011-12-27 04:31 PST, Gian-Carlo Pascutto [:gcp]
mark.finkle: review+
philipp: feedback+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Philipp von Weitershausen [:philikon] 2011-12-24 14:35:50 PST
Created attachment 584231 [details]
logcat

Reproducible every time. Logcat is attached (minus private data spew from the profile migrator)
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 12:11:22 PST
Could be a dupe of bug 712718 but we might need more of your logcat to be sure.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 12:12:52 PST
Since you are on nightly and the fix is on nightly, you could manually re-install and see if the crash is fixed. I suggest manually re-installing since you might not be running long enough to get to check for updates.
Comment 3 Philipp von Weitershausen [:philikon] 2011-12-26 20:54:08 PST
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Could be a dupe of bug 712718 but we might need more of your logcat to be
> sure.

In what way? All previous lines contained profile migrator output (bookmarks & history) that I'm not willing to share publicly. If it helps I can send you a private email with the full logcat, I still have the file.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 20:59:34 PST
(In reply to Philipp von Weitershausen [:philikon] from comment #3)
> (In reply to Mark Finkle (:mfinkle) from comment #1)
> > Could be a dupe of bug 712718 but we might need more of your logcat to be
> > sure.
> 
> In what way? All previous lines contained profile migrator output (bookmarks
> & history) that I'm not willing to share publicly. If it helps I can send
> you a private email with the full logcat, I still have the file.

Oh! I see what you mean now. I assume the java.lang.IllegalStateException is crashing the app.
Comment 5 Gian-Carlo Pascutto [:gcp] 2011-12-27 01:16:29 PST
The actual crash is not in the log pasted. The errors in the log pasted are caused by an unanticipated exception higher up.
Comment 6 Philipp von Weitershausen [:philikon] 2011-12-27 03:36:15 PST
Created attachment 584406 [details]
full logcat (cleaned up)

Here's the full logcat. I cleaned up all private data. Hope this helps.
Comment 7 Gian-Carlo Pascutto [:gcp] 2011-12-27 04:31:19 PST
This is a duplicate of 712718, but I'd like to abuse it to remove that logging, as you're not the first one to complain about it.
Comment 8 Gian-Carlo Pascutto [:gcp] 2011-12-27 04:31:56 PST
Created attachment 584414 [details] [diff] [review]
Patch 1. Reduce logging for Profile Migrator
Comment 9 Philipp von Weitershausen [:philikon] 2011-12-27 04:38:03 PST
Comment on attachment 584414 [details] [diff] [review]
Patch 1. Reduce logging for Profile Migrator

Seems sensible to me (you might want to reflect the morphing in the bug title...). Obsessive logging is rarely a good idea in production code anyway, as it creates lots of unnecessary I/O.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-27 08:02:41 PST
Comment on attachment 584414 [details] [diff] [review]
Patch 1. Reduce logging for Profile Migrator

We want this patch on Aurora too, if the migration code has landed there. Just request approval.
Comment 11 christian 2011-12-29 14:49:41 PST
Comment on attachment 584414 [details] [diff] [review]
Patch 1. Reduce logging for Profile Migrator

[triage comment]
Approved for aurora. Mobile only, low risk
Comment 12 Gian-Carlo Pascutto [:gcp] 2011-12-29 17:45:41 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/7da491d262a3
Comment 13 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-12-30 04:53:49 PST
https://hg.mozilla.org/mozilla-central/rev/7da491d262a3
Comment 14 Gian-Carlo Pascutto [:gcp] 2012-01-09 11:36:43 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/9f80f3664500

Note You need to log in before you can comment on or make changes to this bug.