Crash on firstrun [@ mozalloc_abort | core.odex@0xacb2a ]

RESOLVED DUPLICATE of bug 711988

Status

()

--
critical
RESOLVED DUPLICATE of bug 711988
7 years ago
7 years ago

People

(Reporter: mardeg, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 584298 [details]
aLogcat of the crash

Ice-cream Sandwich 4.0.1
Google Nexus
Kernel 3.0.1-ga052f63
android-build@apa28 #1
Build number ITL41F
(Reporter)

Comment 1

7 years ago
Created attachment 584300 [details]
aLogcat of another crash when going to Settings-> About Nightly
First crash : 

D/GeckoLayerController(18498): setViewportMetrics: v=RectF(0.0, 0.0, 720.0, 1038.0) p=(0.0,291.84415) z=0.29780012 o=0.0,0.0
I/AndroidGraphicBuffer(18498): GL error [glEGLImageTargetTexture2DOES]:                                      501
D/dalvikvm(18498): GC_CONCURRENT freed 326K, 3% free 16376K/16839K, paused 52ms+2ms
E/CursorWindow(18498): Failed to read row 3, column 0 from a CursorWindow which has 0 rows, 5 columns.
W/GeckoGlobalHistory(18498): Rebuilding visited link set...
E/GeckoApp(18498): top level exception

Second crash:
W/TextLayoutCache(19795): computeValuesWithHarfbuzz -- need to force to single run
I/GeckoApp(19795): pause
I/ActivityManager(  174): Displayed org.mozilla.fennec/org.mozilla.gecko.GeckoPreferences: +472ms
I/GeckoApp(19795): stop
E/GeckoApp(19795): top level exception
E/GeckoApp(19795): java.lang.NullPointerException
E/GeckoApp(19795): at org.mozilla.gecko.GeckoPreferences.onPreferenceChange(GeckoPreferences.java:145)
E/GeckoApp(19795): at android.preference.Preference.callChangeListener(Preference.java:885)

E/GeckoApp(18498): java.lang.IllegalStateException: Couldn't read row 3, col 0 from CursorWindow.  Make sure the Cursor is initialized correctly before accessing data from it.
E/GeckoApp(18498): at android.database.CursorWindow.nativeGetLong(Native Method)
E/GeckoApp(18498): at android.database.CursorWindow.getLong(CursorWindow.java:513)
Ignore Comment 2.

First Crash : 

D/GeckoLayerController(18498): setViewportMetrics: v=RectF(0.0, 0.0, 720.0, 1038.0) p=(0.0,291.84415) z=0.29780012 o=0.0,0.0
I/AndroidGraphicBuffer(18498): GL error [glEGLImageTargetTexture2DOES]:                                      501
D/dalvikvm(18498): GC_CONCURRENT freed 326K, 3% free 16376K/16839K, paused 52ms+2ms
E/CursorWindow(18498): Failed to read row 3, column 0 from a CursorWindow which has 0 rows, 5 columns.
W/GeckoGlobalHistory(18498): Rebuilding visited link set...
E/GeckoApp(18498): top level exception
E/GeckoApp(18498): java.lang.IllegalStateException: Couldn't read row 3, col 0 from CursorWindow.  Make sure the Cursor is initialized correctly before accessing data from it.
E/GeckoApp(18498): at android.database.CursorWindow.nativeGetLong(Native Method)
E/GeckoApp(18498): at android.database.CursorWindow.getLong(CursorWindow.java:513)

Second Crash : 
W/TextLayoutCache(19795): computeValuesWithHarfbuzz -- need to force to single run
I/GeckoApp(19795): pause
I/ActivityManager(  174): Displayed org.mozilla.fennec/org.mozilla.gecko.GeckoPreferences: +472ms
I/GeckoApp(19795): stop
E/GeckoApp(19795): top level exception
E/GeckoApp(19795): java.lang.NullPointerException
E/GeckoApp(19795): at org.mozilla.gecko.GeckoPreferences.onPreferenceChange(GeckoPreferences.java:145)
E/GeckoApp(19795): at android.preference.Preference.callChangeListener(Preference.java:885)
bug 712980 java.lang.NullPointerException @ org.mozilla.gecko.GeckoPreferences.onPreferenceChange(GeckoPreferences.java:145) 

bug 711988 Crash on startup - Top Level Exception -- java.lang.IllegalStateException: Couldn't read row 0, col 2 from CursorWindow
Severity: major → critical
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711988
You need to log in before you can comment on or make changes to this bug.