Biff is not making the beep sound when the mail arrives

VERIFIED FIXED in mozilla0.9

Status

MailNews Core
Backend
P1
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Sheela Ravindran, Assigned: racham)

Tracking

Trunk
mozilla0.9
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
buildid:2001-03-08-09 on win98

Preference: play sound when a message arrives checked
compose and send a mail
wait for the biff to go off
Results: biff does go and fetch the mail but does not play the sound.  The sound 
does not go off even when doing get message

This could be a regression bug because I have checked on buildid 2001-03-05-09 
still has the system beep sound when the message arrives
(Reporter)

Comment 1

17 years ago
change qa contact, cc esther and racham
This could be a regression bug.  
QA Contact: esther → sheelar

Comment 2

17 years ago
looks like the sound URL is null when we get it in the biff manager....
i'm getting an assertion there in a debug tip build.
Assignee: mscott → racham

Comment 3

17 years ago
Can this be related to http://bugzilla.mozilla.org/show_bug.cgi?id=71123?

Comment 4

17 years ago
marking nsbeta1+, we need to fix this.  It should be playing the system beep now.   
Keywords: nsbeta1
Priority: -- → P1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 5

17 years ago
Before we try to play sound file at givel url, we were only checking whether or
not we got soundURL object successfully and that is not sufficient. What we
really want to check to see if the soundURL spec has any length (either default
or user specified).

New patch coming up....

Status: NEW → ASSIGNED
(Assignee)

Comment 6

17 years ago
Created attachment 27521 [details] [diff] [review]
patch
(Assignee)

Comment 7

17 years ago
Adding Seth and Gayatri to the cc list.
Keywords: patch, review

Comment 8

17 years ago
looks good. r=gayatrib
sr=sspitzer

I didn't know you could do .get() on a nsXPIDLCString.

that's much cleaner than casting (which is what I've done in the past, but not
anymore!)
(Assignee)

Comment 10

17 years ago
Fix checked in.

Thanks for reviews.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

17 years ago
verified-plays the system sound
win98-2001031515
linux-2001031421
mac-2001031604
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.