Closed Bug 713569 Opened 8 years ago Closed 8 years ago

crash @ gralloc.tegra.so@0x1... on LGE 'Optimus 2X' and LGE 'LG-P99.'

Categories

(Firefox for Android :: General, defect, P1, critical)

12 Branch
ARM
Android
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox11 --- affected
fennec 11+ ---

People

(Reporter: nhirata, Assigned: snorp)

References

Details

(4 keywords, Whiteboard: [native-crash])

Crash Data

From Soccoro:
https://crash-stats.mozilla.com/report/index/0e31d6f0-639e-4d76-b58c-963932111224

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	gralloc.tegra.so 	gralloc.tegra.so@0x1b88 	
1 	libnvwsi.so 	NvWsiGetDispMgrBackend 	
2 	libEGL_tegra.so 	libEGL_tegra.so@0x6e81 	
3 	libEGL_tegra.so 	libEGL_tegra.so@0xf732 	
4 	libEGL_tegra.so 	libEGL_tegra.so@0x7733 	
5 	libEGL.so 	libEGL.so@0x8cb6 	
6 	dalvik-heap (deleted) 	dalvik-heap @0x574e56 	
7 	libEGL.so 	libEGL.so@0x3827 	
8 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x18f2de 	
9 	libandroid_runtime.so 	libandroid_runtime.so@0x351cb 	
10 	libdvm.so 	libdvm.so@0x11eb6 	
11 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x53d86 	
12 	libdvm.so 	libdvm.so@0x4355d 	
13 	system@framework@framework.jar@classes.dex 	system@framework@framework.jar@classes.dex@0x4fe69e 	
14 	libandroid_runtime.so 	libandroid_runtime.so@0x35183 	
15 	system@framework@framework.jar@classes.dex 	system@framework@framework.jar@classes.dex@0x25a506 	
16 	dalvik-heap (deleted) 	dalvik-heap @0x21926 	
17 	libdvm.so 	libdvm.so@0x1207e 	
18 	libdvm.so 	libdvm.so@0x170ca 	
19 	libdvm.so 	libdvm.so@0x1c086 	
20 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1f8dc2 	
21 	libdvm.so 	libdvm.so@0x1c112 	
22 	libdvm.so 	libdvm.so@0x1affa 	
23 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x15cf4e 	
24 	dalvik-heap (deleted) 	dalvik-heap @0x8547fe 	
25 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1f917e 	
26 	dalvik-heap (deleted) 	dalvik-heap @0x18fff6e 	
27 	libdvm.so 	libdvm.so@0xa3b06 	
28 	libdvm.so 	libdvm.so@0x16daa 	
29 	libdvm.so 	libdvm.so@0x16e22 	
30 	libdvm.so 	libdvm.so@0x16cca 	
31 	libdvm.so 	libdvm.so@0x16cf2 	
32 	libdvm.so 	libdvm.so@0x16d22 	
33 	libdvm.so 	libdvm.so@0x16d46 	
34 	libdvm.so 	libdvm.so@0x7940b 	
35 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x16c28a 	
36 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x16c28a 	
37 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x15cf4e 	


Note:  All of the crash logs for this particular crash show 2 devices.
1. AdapterDescription: 'Android, Model: 'Optimus 2X', Product: 'lge_star', Manufacturer: 'LGE', Hardware: 'p990''.
LGE Optimus 2X
lge/lge_star/p990/p990:2.2.2/FRG83G/lgp990-V10b.2ED2ADCFFC:user/release-keys


2. AdapterDescription: 'Android, Model: 'LG-P999', Product: 'lge_lge_star', Manufacturer: 'LGE', Hardware: 'tegra''.
LGE LG-P999
lge/lge_lge_star/p999:2.3.3/GRI40/lgp999-V21e.41fdc8a2:user/release-keys
Summary: crash [@ gralloc.tegra.so@0x1b88 ] → crash [@ gralloc.tegra.so@0x1b88 ] on LGE 'Optimus 2X' and LGE 'LG-P999'
Assignee: nobody → snorp
Priority: -- → P1
Crash Signature: [@ gralloc.tegra.so@0x1b88 ]
tracking-fennec: --- → 11+
Not sure if this is the same crash signature or not:
From socorro : https://crash-stats.mozilla.com/report/index/f313168c-ba48-4090-97b5-867942120107

0 	gralloc.tegra.so 	gralloc.tegra.so@0x1b88 	
1 	libnvwsi.so 	NvWsiGetDispMgrBackend 	
2 	libEGL_ORG_CF3D.so 	libEGL_ORG_CF3D.so@0x6e85 	
3 	libEGL_ORG_CF3D.so 	libEGL_ORG_CF3D.so@0xf732 	
4 	libEGL_ORG_CF3D.so 	libEGL_ORG_CF3D.so@0x7737 	
5 	libEGL.so 	libEGL.so@0x8cb6 	
6 	libEGL_tegra.so 	libEGL_tegra.so@0x43bf 	
7 	libEGL_tegra.so 	libEGL_tegra.so@0x439b 	
8 	dalvik-heap (deleted) 	dalvik-heap @0x567a9e 	
9 	libEGL.so 	libEGL.so@0x3827 	
10 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x18f926 	
11 	libandroid_runtime.so 	libandroid_runtime.so@0x35553 	
12 	libdvm.so 	libdvm.so@0x11eb6 	
13 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x53e06 	
14 	libdvm.so 	libdvm.so@0x4355d 	
15 	system@framework@framework.jar@classes.dex 	system@framework@framework.jar@classes.dex@0x50453d 	
16 	libandroid_runtime.so 	libandroid_runtime.so@0x3550b 	
17 	libandroid_runtime.so 	libandroid_runtime.so@0x3550b 	
18 	dalvik-jit-code-cache (deleted) 	dalvik-jit-code-cache @0x726 	
19 	libdvm.so 	libdvm.so@0x1c086 	
20 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1fee3a 	
21 	libdvm.so 	libdvm.so@0x1c112 	
22 	libdvm.so 	libdvm.so@0x1affa 	
23 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x829d6 	
24 	dalvik-heap (deleted) 	dalvik-heap @0x3b6ffe 	
25 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x200196 	
26 	dalvik-heap (deleted) 	dalvik-heap @0x18fff6e 	
27 	libdvm.so 	libdvm.so@0xa3b06 	
28 	libdvm.so 	libdvm.so@0x16daa 	
29 	libdvm.so 	libdvm.so@0x16e22 	
30 	libdvm.so 	libdvm.so@0x16cca 	
31 	libdvm.so 	libdvm.so@0x16cf2 	
32 	libdvm.so 	libdvm.so@0x16d22 	
33 	libdvm.so 	libdvm.so@0x16d46 	
34 	libdvm.so 	libdvm.so@0x7940b 	
35 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x8373e 	
36 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x8370a 	
37 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x829d6
Duplicate of this bug: 716618
There's a third device:
3.AdapterDescription: 'Android, Model: 'LG-P990', Product: 'lge_star', Manufacturer: 'lge', Hardware: 'tegra''.
Crash Signature: [@ gralloc.tegra.so@0x1b88 ] → [@ gralloc.tegra.so@0x1b88] [@ gralloc.tegra.so@0x1a88] [@ gralloc.tegra.so@0x1b8f]
Summary: crash [@ gralloc.tegra.so@0x1b88 ] on LGE 'Optimus 2X' and LGE 'LG-P999' → crash @ gralloc.tegra.so@0x1... on LGE 'Optimus 2X' and LGE 'LG-P99.'
The last build seen on socorro is at least in buildid 20111222150239.  Most crashes happen in 1 minute or less.
(In reply to Naoki Hirata :nhirata from comment #5)
> The last build seen on socorro is at least in buildid 20111222150239.
The last crashes happen in 12.0a1/20120117031056, e.g. bp-1a94b249-dd38-4101-8486-c51a22120117, so it's not fixed.
(In reply to Scoobidiver from comment #6)
> (In reply to Naoki Hirata :nhirata from comment #5)
> > The last build seen on socorro is at least in buildid 20111222150239.
> The last crashes happen in 12.0a1/20120117031056, e.g.
> bp-1a94b249-dd38-4101-8486-c51a22120117, so it's not fixed.

Sorry I meant "earliest seen crash" in comment 5, not "last build seen".  I did not mean to say it was fixed, I was commenting in terms of the start date for trying to find a regression range if steps to reproduce the issue are found.
(In reply to Naoki Hirata :nhirata from comment #5)
> The last build seen on socorro is at least in buildid 20111222150239.
It first appeared a few hours sooner in 12.0a1/20111222040248.

(In reply to Naoki Hirata :nhirata from comment #7)
> I was commenting in terms of the start date for trying to find a regression
> range if steps to reproduce the issue are found.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4e4878620bb5&tochange=d9e4c34ca1c6
bug 670930 belongs to the regression range.
Keywords: regression
This device is not in the whitelist for gralloc now, so the crash is fixed (avoided). Bug 719233 has the whitelist.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I was able to reproduce this issue on the latest Nightly build.
I enabled "direct-texture.force.enabled" = true from about:config and I browsed to planet.mozilla.org.

--
Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120123
Firefox/12.0a1 Fennec/12.0a1
Device: LG P999 (G2x)
OS: Android 2.3.3
Status: RESOLVED → REOPENED
Keywords: reproducible
Resolution: FIXED → ---
(In reply to Cristian Nicolae (:xti) from comment #10)
> I was able to reproduce this issue on the latest Nightly build.
> I enabled "direct-texture.force.enabled" = true from about:config and I
> browsed to planet.mozilla.org.

Turning that pref on ignores the whitelist I added specifically to fix this bug, so yes, it's going to crash.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.