Last Comment Bug 71358 - XUL-related changes from IBM bidi project
: XUL-related changes from IBM bidi project
Status: VERIFIED FIXED
r/sr=hyatt 2001-05-10 16:08 wait for ...
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla0.9.1
Assigned To: Frank Tang
:
:
Mentors:
Depends on:
Blocks: 80130
  Show dependency treegraph
 
Reported: 2001-03-08 15:13 PST by Erik van der Poel
Modified: 2008-07-31 02:58 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
diffs for a XUL-related file from IBM bidi project (5.45 KB, patch)
2001-03-08 15:15 PST, Erik van der Poel
no flags Details | Diff | Splinter Review
new patch (7.76 KB, patch)
2001-05-10 15:54 PDT, Frank Tang
no flags Details | Diff | Splinter Review

Description Erik van der Poel 2001-03-08 15:13:26 PST
This bug report will be used to attach the diffs for XUL-related files from the
IBM bidi project.
Comment 1 Erik van der Poel 2001-03-08 15:15:02 PST
Created attachment 27176 [details] [diff] [review]
diffs for a XUL-related file from IBM bidi project
Comment 2 Erik van der Poel 2001-03-08 15:15:31 PST
Dave, please (have someone) review these changes. Thanks!
Comment 3 David Hyatt 2001-03-08 15:44:21 PST
IBM needs to patch the outliner code as well (which just recently landed).  It
draws and crops its own text.
Comment 4 Frank Tang 2001-03-19 17:05:31 PST
set to moz 0.9
Comment 5 Erik van der Poel 2001-04-09 14:17:10 PDT
David, could we have an r or sr for the patch that is already in this bug
report, or do you want to see the outliner changes first?
Comment 6 Frank Tang 2001-04-11 11:55:36 PDT
Do we need this to trun on IBMBID flag ? Can we land this later if hyatt do not 
have time to look at it soon?
Comment 7 Frank Tang 2001-05-07 23:42:41 PDT
erik resign. reassign all his bug to ftang for now.
Comment 8 Frank Tang 2001-05-08 00:36:23 PDT
hyatt- pleae review this as module owner.
Comment 9 David Hyatt 2001-05-09 12:07:32 PDT
It looks like the bidi engine leaks.  nsIBidi is fetched without using a COM 
ptr.
Comment 10 Frank Tang 2001-05-10 12:41:31 PDT
simon- 
I think we should use nsCOMPtr inside nsBidiPresUtils for mBidiEngine and 
mUnicodeUtils. Also, we should AddRef for GetBidiEngine. I am working on a fix 
for this
Comment 11 Frank Tang 2001-05-10 15:54:03 PDT
here is a better patch
1. we make the nsBidiPresUtil using nsCOMPtr for service so we won't leak them
2. we use nsCOMPtr in the xul so we won't leak them. 
the nsBidiPresUtil itself is not an com object so we don't do that.
Comment 12 Frank Tang 2001-05-10 15:54:39 PDT
Created attachment 33966 [details] [diff] [review]
new patch
Comment 13 Frank Tang 2001-05-10 15:56:47 PDT
change stuats to
wait for hyatt's review for new patch since 2001-05-10 15:54
Comment 14 David Hyatt 2001-05-10 16:08:55 PDT
ok, sr=hyatt
Comment 15 Frank Tang 2001-05-15 05:01:04 PDT
fixed and check in
Comment 16 John Morrison 2001-06-05 19:17:31 PDT
rs verify checkin.

Note You need to log in before you can comment on or make changes to this bug.