Fennec crash loading aerobie.com/products/aeropress.htm on Droid Charge (java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of)

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P1
critical
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: Janet Swisher, Assigned: snorp)

Tracking

({crash})

11 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +, fennec11+)

Details

(Whiteboard: [MTD], [native-crash], URL)

(Reporter)

Description

6 years ago
Web page or screen you were on when you saw the issue: 
http://aerobie.com/products/aeropress.htm

Steps to reproduce:
1. Using Android 11.0a2 on Samsung Droid Charge with Android 2.3.6, go to http://aerobie.com
2. Click link for "AeroPress™ Coffee and Espresso Maker" 
3. Aurora partially loads the page, then quits, returning to home screen, no longer listed in Task manager. 

What you expected: 
Aurora should load the page without crashing.

Crash report ID (if applicable): 
6da112ef-9eb6-4bab-8b62-de79a2111226

P.S. The people who make the Aerobie flying discs also make a coffee press. Who knew?
Looks like it OOM dued to gralloc not being able to allocate memory

12-26 17:26:11.620: I/AndroidGraphicBuffer(3615): No valid EGLImage!
12-26 17:26:11.730: E/gralloc(3615): gralloc_alloc_buffer() failed to allcoate UMP memory
12-26 17:26:11.730: W/GraphicBufferAllocator(3615): alloc(1024, 2048, 4, 00000130, ...) failed -1 (Operation not permitted)
12-26 17:26:11.730: E/gralloc(3615): Locking invalid buffer, returning error
12-26 17:26:11.730: W/GraphicBufferMapper(3615): lock(...) failed -22 (Invalid argument)
12-26 17:26:11.730: E/gralloc(3615): Unlocking invalid buffer, returning error
12-26 17:26:11.730: W/GraphicBufferMapper(3615): unlock(...) failed -22 (Invalid argument)
12-26 17:26:11.730: E/GeckoSoftwareLayerClient(3615): Bad viewport description: 
12-26 17:26:11.730: W/System.err(3615): java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of 
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:201)
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.endDrawing(GeckoSoftwareLayerClient.java:211)
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:460)
12-26 17:26:11.730: E/(3615): egl_image* _egl_create_image_ANDROID_native_buffer(egl_display*, egl_context*, void*, EGLint*, void*) failed to map native buffer
12-26 17:26:11.730: I/AndroidGraphicBuffer(3615): No valid EGLImage!
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:107)
12-26 17:26:11.730: W/System.err(3615): Caused by: org.json.JSONException: End of input at character 0 of 
12-26 17:26:11.730: W/System.err(3615): 	at org.json.JSONTokener.syntaxError(JSONTokener.java:446)
12-26 17:26:11.730: W/System.err(3615): 	at org.json.JSONTokener.nextValue(JSONTokener.java:93)
12-26 17:26:11.730: W/System.err(3615): 	at org.json.JSONObject.<init>(JSONObject.java:154)
12-26 17:26:11.730: W/System.err(3615): 	at org.json.JSONObject.<init>(JSONObject.java:171)
12-26 17:26:11.730: W/System.err(3615): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:171)
12-26 17:26:11.730: W/System.err(3615): 	... 5 more
12-26 17:26:11.955: E/gralloc(3615): gralloc_alloc_buffer() failed to allcoate UMP memory
12-26 17:26:11.960: W/GraphicBufferAllocator(3615): alloc(1024, 2048, 4, 00000130, ...) failed -1 (Operation not permitted)
12-26 17:26:11.960: E/gralloc(3615): Locking invalid buffer, returning error
12-26 17:26:11.960: W/GraphicBufferMapper(3615): lock(...) failed -22 (Invalid argument)
12-26 17:26:11.960: E/gralloc(3615): Unlocking invalid buffer, returning error
12-26 17:26:11.960: W/GraphicBufferMapper(3615): unlock(...) failed -22 (Invalid argument)
Severity: normal → critical
Keywords: crash
Whiteboard: [MTD] → [MTD], [native-crash]
Assignee: nobody → snorp
Dupe of bug 712945?
Priority: -- → P1
tracking-fennec: --- → 11+

Updated

6 years ago
Summary: Aurora quits when loading aerobie.com/products/aeropress.htm → Aurora quits when loading aerobie.com/products/aeropress.htm (java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of)
Keywords: fennecnative-releaseblocker
the assertion is that this is already fixed. Please reopen if you can reproduce
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

6 years ago
Still happening for me in 13.0a1 (2012-02-23)
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Cannot seem to repro on the Samsung Galaxy S II; need to try a different device closer to Samsung Droid Charge.
Summary: Aurora quits when loading aerobie.com/products/aeropress.htm (java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of) → Fennec crash loading aerobie.com/products/aeropress.htm on Droid Charge (java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of)
Works for me using the current maple tinderbox build on a Droid Charge which is what comment 3 referred to. Once that branch is merged back into mozilla-central it will work there too.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
blocking-fennec1.0: --- → +
You need to log in before you can comment on or make changes to this bug.