Last Comment Bug 713676 - Keyboard shortcuts (ESC, RETURN) no longer work if the content area loses focus.
: Keyboard shortcuts (ESC, RETURN) no longer work if the content area loses focus.
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: ---
Assigned To: Paul Rouget [:paul]
:
Mentors:
Depends on: 703031
Blocks: 691884
  Show dependency treegraph
 
Reported: 2011-12-27 10:00 PST by Johan C
Modified: 2012-01-30 07:29 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Johan C 2011-12-27 10:00:44 PST
See: https://bugzilla.mozilla.org/show_bug.cgi?id=691884#c33 for detailed instructions on how to reproduce.

I can also reproduce this with the ENTER key.
Comment 1 Kevin Brosnan [:kbrosnan] 2011-12-28 12:07:56 PST
Copying over str

Steps to reproduce:
1. Open 2 tabs in Firefox
2. Go to www.google.com
3. Start the Inspect mode
4. Click on the google logo
5. Click on the other tab
6. Click back on google tab
7. Press ESC

Actual results:
Nothing happens

Expected results:
Inspect mode should exit
Comment 2 Paul Rouget [:paul] 2012-01-03 02:44:41 PST
ESC, RETURN, left, right, top and bottom shortcuts don't work if the veil is not focused.

This also happens when the breadcrumbs are clicked (when they get the focus).

Should ESC should also work from the Style Panel?

I think this is a pretty annoying, and I think this should be fixed in Firefox 11 (Aurora).
Comment 3 Paul Rouget [:paul] 2012-01-20 06:42:00 PST
This has been fixed by bug 703031
Comment 4 Paul Silaghi, QA [:pauly] 2012-01-30 07:29:15 PST
The issue is not reproducible on Firefox 12:
Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120129 Firefox/12.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0a1) Gecko/20120129 Firefox/12.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120130 Firefox/12.0a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120129 Firefox/12.0a1

Setting the resolution to verified fixed.

Note You need to log in before you can comment on or make changes to this bug.