press/drag to scroll/pan only works about half the time

VERIFIED DUPLICATE of bug 709817

Status

()

Firefox for Android
General
P3
normal
VERIFIED DUPLICATE of bug 709817
6 years ago
6 years ago

People

(Reporter: myk, Assigned: wesj)

Tracking

11 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec11+)

Details

(Whiteboard: [MTD])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
On my Samsung Galaxy S running Android 2.3 and the latest Aurora build of Fennec Native, when I press the screen and drag my finger to scroll/pan web content, the page only pans about half the time.

This seems to happen on every page I load, although I particularly notice it on New York Times articles.

Steps to Reproduce:

1. Go to http://mobile.nytimes.com/;
2. Tap a headline to load an article page;
3. Press/drag to pan vertically through the page.

Expected Results: each time I press/drag, the page pans.

Actual Results: the page pans only about half the time I press/drag.

Additional Information:

I thought perhaps the problem was specific to where I press my finger, but I haven't been able to identify a pattern. NYT article pages are text-heavy, and the problem seems to occur at random (about half the time) when I press on text.
Does this happen while the page loading or after the load has finished? Can you reproduce it on other web sites as well?
Assignee: nobody → wjohnston
Priority: -- → P3
Duplicate of this bug: 713854
(Reporter)

Comment 3

6 years ago
It happens after the load has finished.  I can reproduce it on other sites, although it happens less often on some sites and seems to happen less often on nytimes.com as well in today's build: ~25% of the time on an nytimes.com article, and rarely on about:license.
(Reporter)

Comment 4

6 years ago
It seems to happen a lot on this baycitizen.org article page:

http://www.baycitizen.org/blogs/sports-riff/winning-wont-get-any-easier-tedford/
Duplicate of this bug: 714535
This sounds like a pan/zoom issue; if you could provide logcat output while reproducing the problem that would help in diagnosing the exact problem. (I'm unable to reproduce this on devices I have). If you have the android developer tools installed, use "adb logcat" to get the logcat output, otherwise you can also install the "aLogcat" app from the android market to get it.
(Reporter)

Comment 7

6 years ago
Created attachment 585442 [details]
log taken with alogcat

I don't have the Android developer tools installed, so I installed the alogcat app, cleared the log in it, started Aurora (which loaded a Facebook page initially), browsed to the New York Times mobile home page, opened an article page, and pressed/dragged about ten times to pan through the article, three of which times the browser failed to pan.

Then I switched back to alogcat and saved the log.  Here's the log file alogcat saved.
Awesome, thanks for the log! Looking at the log, I realized that I had already fixed this problem before but apparently the patches never went into Aurora, since it landed on m-i before the cutover for FF12 and landed on m-c after the cutover. Or something like that. Marking this bug as a dupe of bug 709817, and I'll request aurora approval for those patches.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709817
(Reporter)

Comment 9

6 years ago
I just tested in a Nightly build from December 22, right after the changes landed on central, and I don't see the problem there, so I can confirm that this is fixed on central and thus a duplicate of that other bug.
Status: RESOLVED → VERIFIED
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.