Last Comment Bug 71370 - check in several layout related changes from IBM bidi project
: check in several layout related changes from IBM bidi project
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla0.8.1
Assigned To: Erik van der Poel
: Chris Petersen
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 16:25 PST by Erik van der Poel
Modified: 2005-03-17 13:34 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
diffs for several layout related files from IBM bidi project (64.01 KB, patch)
2001-03-08 16:27 PST, Erik van der Poel
no flags Details | Diff | Splinter Review
mozilla/layout/base/public/nsBidiPresUtils.h (5.18 KB, text/plain)
2001-03-08 17:06 PST, Erik van der Poel
no flags Details
mozilla/layout/base/src/nsBidiPresUtils.cpp (31.42 KB, text/plain)
2001-03-08 17:06 PST, Erik van der Poel
no flags Details

Description Erik van der Poel 2001-03-08 16:25:29 PST
This bug report will be used to attach a number of changes in the layout area
from the IBM bidi project.
Comment 1 Erik van der Poel 2001-03-08 16:27:41 PST
Created attachment 27196 [details] [diff] [review]
diffs for several layout related files from IBM bidi project
Comment 2 Erik van der Poel 2001-03-08 16:29:02 PST
Yesterday, Marc kindly came up to Mountain View to go over these changes, and
approved them for check-in. I've also gone over them.

r=attinasi
sr=erik
Comment 3 Erik van der Poel 2001-03-08 17:06:09 PST
Created attachment 27204 [details]
mozilla/layout/base/public/nsBidiPresUtils.h
Comment 4 Erik van der Poel 2001-03-08 17:06:52 PST
Created attachment 27205 [details]
mozilla/layout/base/src/nsBidiPresUtils.cpp
Comment 5 Erik van der Poel 2001-03-08 17:07:50 PST
nsBidiPresUtils.{cpp,h} have also been reviewed by attinasi and erik.
Comment 6 Erik van der Poel 2001-03-12 14:48:03 PST
Changes and new files checked in.
Comment 7 Chris Petersen 2001-05-24 12:40:25 PDT
Marking verified per last comments
Comment 8 Kai Engert (:kaie) (on vacation) 2003-06-06 12:59:27 PDT
The patch in this bug contains a test that is commented as
  this must be a non-renderable frame creatd at the 
  end of the line by Bidi reordering

I suspect the assumption that an empty frame is caused by "BIDI reordering at
the end of a line" is incorrect in the general case.

Removing this text altogether seems to fix bug 202046.

I guess we should find a different test for identifying empty frames caused by
Bidi reordering at line ends? Or can this test and action get removed altogether?

Note You need to log in before you can comment on or make changes to this bug.