Closed Bug 713814 Opened 8 years ago Closed 8 years ago

Ctrl+Drag/Control+Drag moves messages instead of copying them

Categories

(Thunderbird :: Folder and Message Lists, defect)

9 Branch
x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ajgelado, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [datalossy!][confirmed for tb9, fixed by ? for tb10])

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

1) Press and hold the left Control key.
2) Clic a message in the message list and hold the mouse button.
3) Drag the mouse pointer to the folder list, and place it over a different folder.
4) Release the mouse button.
It started happening after upgrading to Thunderbird 9.


Actual results:

While dragging, the mouse pointer indicates a move operation (it was an arrow with a dotted box bellow it) instead of a copy operation (an arrow with a "plus" sign bellow it). When the button is released, the message is moved to the folder.


Expected results:

While dragging, the mouse pointer should indicate a copy operation (an arrow with a "plus" sign bellow it). When the button is released, the message should be copied to the folder.
(In reply to Antonio Rodríguez from comment #0)
This works for me (dragging with CTRL copies file, while dragging without it moves it):
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
Application Build ID: 20111222141531
WFM too with Mozilla/5.0 (Windows NT 6.1; rv:12.0a1) Gecko/20111229 Thunderbird/12.0a1

Releases mouse button before to release CTRL button
Duplicate of this bug: 714466
Keywords: regression
Summary: Control+Drag moves a message instead of copying it → Ctrl/Control+Drag moves a message instead of copying it
Same problem with Firefox 9.0.1 for Windows XP SP3.  Holding CTRL while dragging messages moves instead of copying.  The mouse pointer never even indicates a copy will occur (no "plus" sign). 

The only good news is that this bug only affects the version 9 branch.  The problem does not exist in Thunderbird 10 (beta) and up.  So the "work around" is to use the beta build.  That or use the menus, instead of drag/drop for copying.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I am having the same problem with Thunderbird 9.0.1 on Windows Vista 32-bit.  
User Agent Mozilla/5.0 (Windows NT 6.0; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
Application Build ID 20111222160251

The drag icon does not contain a "+" when the CTRL key is held down, and dropping the message moves it instead of copying it.  

This started happening after I upgraded to Thunderbird 9.0.x
Same here on Windows XP SP3 with Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20111222 Thunderbird/9.0.1, Application Build ID 20111222160251
It stopped working with TB 9.x
Duplicate of this bug: 715539
Blocks: 715429
Same here after update from SeaMonkey 2.5 to SeaMonkey 2.6.1 (Windows XP SP3).
Duplicate of this bug: 718662
rsx11, are you still xp?  can you reproduce?
The problem does not occur in Thunderbird 10 and up, so likely it was already fixed by another bug.    Unless a patch is going to made specifically for Thunderbird 9 before 10 is released, it might not be worth investigating this. 

Personally I'm just using TB 10 as a work around.
(In reply to Wayne Mery (:wsmwk) from comment #10)
> rsx11, are you still xp?  can you reproduce?

If QA is still needed despite comment #11, I could get an XP installation running again, but JoeS and Bozz are both running XP full time AFAIK and may be able to test it easier.
XP Pro SP3 TB 9.0.1 - confirmed as per subject of this bug.
Jay, it seems to be known that 9.0 is broken, the question is if it's fixed on 10.0.

You can download 10.0 beta 4 from http://www.mozilla.org/thunderbird/channel
(In reply to rsx11m from comment #12)
> (In reply to Wayne Mery (:wsmwk) from comment #10)
> > rsx11, are you still xp?  can you reproduce?
> 
> If QA is still needed despite comment #11, I could get an XP installation
> running again, but JoeS and Bozz are both running XP full time AFAIK and may
> be able to test it easier.

No problem with XP and Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120119 Thunderbird/12.0a1.
Sorry, misinterpreted the comment.

10.0b4 - drag/drop moves, not copies. From the right-click menu, copy to: xxx does copy and not moves.
(In reply to jay garcia from comment #16)
> Sorry, misinterpreted the comment.
> 
> 10.0b4 - drag/drop moves, not copies. From the right-click menu, copy to:
> xxx does copy and not moves.

You have to hold down CTRL to copy.  It works for me under the latest pushed out 10 beta load under XP.  Doesn't work under 9.0.1.
Yes, that works. But why is it a mystery to the user? Added to the UI at some point maybe?
Wayne, Roland: Looks like WFM for the function as confirmed by a couple of users, anything to do wrt documentation of that feature?
(sorry, removed one keyword which still was supposed to stick around...)
Keywords: regression
(In reply to Roland Tanglao :rolandtanglao from comment #21)
> documented here:
> https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts/revision/
> 5652

Nice page on the shortcuts Roland, but I see nothing about Drag and Drop options there.
(CTRL vs !CTRL)
So this is still a bug for TB 9 and WFM for TB10
Nothing has "fixed" this for TB9
Resolution: FIXED → WORKSFORME
(In reply to Joe Sabash from comment #22)
> (In reply to Roland Tanglao :rolandtanglao from comment #21)
> > documented here:
> > https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts/revision/
> > 5652
> 
> Nice page on the shortcuts Roland, but I see nothing about Drag and Drop
> options there.
> (CTRL vs !CTRL)
ah you are right, i meant to change it to WFM, thanks for doing that Joe!

I believe this snippet is the Drag and Drop Options docs you are looking for:
"Copy messages to another folder	Select Multiple messages using Ctrl and then hold down Ctrl and drag to destination folder
Move messages to another folder	Select Multiple messages using Ctrl and then drag to destination folder "

If you don't see that in:
https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts
it's probably due to caching issues, please Control R to reload the page and you will eventually see it.
Marking WONTFIX because this was filed on version 9 and it's fixed in v10.
Resolution: WORKSFORME → WONTFIX
(In reply to Roland Tanglao :rolandtanglao from comment #23)
> ah you are right, i meant to change it to WFM, thanks for doing that Joe!
> 
> I believe this snippet is the Drag and Drop Options docs you are looking for:
> "Copy messages to another folder	Select Multiple messages using Ctrl and
> then hold down Ctrl and drag to destination folder
> Move messages to another folder	Select Multiple messages using Ctrl and then
> drag to destination folder "
> 
> If you don't see that in:
> https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts
> it's probably due to caching issues, please Control R to reload the page and
> you will eventually see it.

Yes, that describes how it should work. It has worked that way up to Thunderbird 8.0. I filed the original bug because Ctrl+drag stopped copying messages in TB 9.0, which means it doesn't work according to the documentation.

Anyway, with the bug marked as WONTFIX just a few days to the launch of TB 10 (which supposedly fizes the bug), I have downgraded to TB 8.0 - I really need to keep copies of the same mail in several folders, and making them via the context menu is difficult and error-prone.
(In reply to Roland Tanglao :rolandtanglao from comment #23)
> (In reply to Joe Sabash from comment #22)
> > (In reply to Roland Tanglao :rolandtanglao from comment #21)
> > > documented here:
> If you don't see that in:
> https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts
> it's probably due to caching issues, please Control R to reload the page and
> you will eventually see it.

Yeah, I see it now good Doc

(In reply to jay garcia from comment #24)
> Marking WONTFIX because this was filed on version 9 and it's fixed in v10.

Maybe someone _will_ fix it in 9.0 Jay

https://developer.mozilla.org/en/What_to_do_and_what_not_to_do_in_Bugzilla


Resolving bugs as WONTFIX

Bugs should not be marked WONTFIX by the normal bug triager. The decision to mark a bug WONTFIX is reserved for module owners or module peers.

It may cause misunderstandings, and is way too final.
Anyhow, enough of this bug spamming.
Let's keep this consistent with SeaMonkey bug 715429 which resolved WFM.
If someone cares, we can set status-thunderbird9 to "wontfix".  ;-)

An overall resolution of WONTFIX would imply that it never would be fixed.
If fixed by another bug, resolve as FIXED with whiteboard [fixed by bug ...]
(at least that's my reading how it's supposed to work).
Resolution: WONTFIX → WORKSFORME
Works for me on Thunderbird 10.0 release. Will the 9.x line have any security releases, or will the users supposed to upgrade to 10.x? In the latter case, maybe it would be a good idea marking this bug as WONTFIX (at least on Thunderbird 9, as suggested by rsx11m).
(In reply to Joe Sabash from comment #22)
> (In reply to Roland Tanglao :rolandtanglao from comment #21)
> > documented here:
> > https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts/revision/
> > 5652
> 
> Nice page on the shortcuts Roland, but I see nothing about Drag and Drop
> options there.

Ftr: The "nice page on the shortcuts" was completely redone and updated by me (Bug 721666), and Roland kindly added the drag'n'drop shortcuts... ;)

> (CTRL vs !CTRL)
> So this is still a bug for TB 9
> Nothing has "fixed" this for TB9

Confirming this bug for tb9 on win XP. Isn't this basic enough functionality to roll out a maintenance fix for tb9? This can easily cause major dataloss if you think you copied messages while in fact you moved them.
Summary: Ctrl/Control+Drag moves a message instead of copying it → Ctrl+Drag/Control+Drag moves messages instead of copying them
Whiteboard: [datalossy!][confirmed for tb9, fixed by ? for tb10]
I don't think this in scope for a security release, even if someone would spend time trying to identify a fix.
(especially given that 10.0 was released yesterday and is not affected by this bug...)
You need to log in before you can comment on or make changes to this bug.