Closed Bug 713815 Opened 8 years ago Closed 8 years ago

Addons with compatibility overrides are still able to be installed

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla12
Tracking Status
firefox10 --- verified
firefox11 --- verified
firefox12 --- verified

People

(Reporter: Unfocused, Assigned: Unfocused)

Details

(Whiteboard: [qa!])

Attachments

(1 file)

1. Have compatible-by-default enabled
2. Find addon with compatibility override matching app/addon version
3. Attempt install of that addon

Actual result:
* Addon will install, though after a restart the compatibility override is correctly applied

Expeced result:
* Addon not allowed to install, incompatible warning shown


Found during QA, by Virgil Dicu. I explicitly remember manually testing this, but there doesn't seem to be a unit test for it, so it regressed somehow.
Attached patch Patch v1Splinter Review
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Attachment #584531 - Flags: review?(dtownsend)
Attachment #584531 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/integration/fx-team/rev/5fdc72d7ac91
Flags: in-testsuite+
Flags: in-litmus-
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/5fdc72d7ac91
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Comment on attachment 584531 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Regression caused by (bug #): bug 693906
User impact if declined: Add-ons with compatibility overrides that make them incompatible will still be able to be installed. They will correctly be detected as incompatible after a restart, however.
Testing completed (on m-c, etc.): On m-c since the 1st. Has automated tests. I've manually verified the fix using latest nightly, but QA has yet to independently verify it.
Risk to taking this patch (and alternatives if risky): Low risk. Just updating a property before the addon install is allowed to proceed. The code that calculates the value of that property is unchanged, and is used throughout the Add-ons Manager. Code is tested well via xpcshell test.
Attachment #584531 - Flags: approval-mozilla-beta?
Attachment #584531 - Flags: approval-mozilla-aurora?
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120102 Firefox/12.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20120103 Firefox/12.0a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120103 Firefox/12.0a1

Verified on Firefox 12 (with Mac OS 1.6, Ubuntu 11.10, Windows 7) with Add-on Compatibility reporter, v 1.0. The incompatible warning is now displayed when attempting to install it.
I think we should take this into 10 because that's when we're debuting this new and very important compatibility mode.
Comment on attachment 584531 [details] [diff] [review]
Patch v1

[Triage Comment]
We need this to continue testing add-ons compatible by default. Let's take on Aurora 11 and Beta 10 ASAP in order to make it into today's beta build.
Attachment #584531 - Flags: approval-mozilla-beta?
Attachment #584531 - Flags: approval-mozilla-beta+
Attachment #584531 - Flags: approval-mozilla-aurora?
Attachment #584531 - Flags: approval-mozilla-aurora+
Landed:

http://hg.mozilla.org/releases/mozilla-aurora/rev/63fdb98f7e96
http://hg.mozilla.org/releases/mozilla-beta/rev/aa49b359456f

Note that aurora had a conflict..."file toolkit/mozapps/extensions/test/addons/test_install6/install.rdf already exists". I looked at it manually and just used `hg transplant --continue` as that change looked to already be on aurora.
Whiteboard: [qa+]
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a2) Gecko/20120110 Firefox/11.0a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a2) Gecko/20120110 Firefox/11.0a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a2) Gecko/20120110 Firefox/11.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0

Verified on Beta3 (Firefox 10), Aurora (Firefox 11) and on Nightly (12)-comment 5 with Add-on compatibility reporter version 1.0. Checked on Mac OS 10.6, Ubuntu 11.10 and Windows 7. 
The add-on can no longer be installed with compatible by default enabled.
Setting to verified.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.