Last Comment Bug 713822 - Simplify @media queries
: Simplify @media queries
Status: RESOLVED FIXED
[good first bug][mentor=dao][lang=css]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Firefox 12
Assigned To: Thomas Prip Vestergaard [:prip]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-28 01:26 PST by Dão Gottwald [:dao]
Modified: 2012-01-08 04:50 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bug 713822 - Simplify @media queries (18.19 KB, patch)
2012-01-05 14:59 PST, Thomas Prip Vestergaard [:prip]
dao+bmo: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2011-12-28 01:26:31 PST
Wherever we write "@media all and (whatever) {", this can be simplified to "@media (whatever) {". Affected files: http://mxr.mozilla.org/mozilla-central/search?string=%40media+all+and+%28&find=%2Fthemes%2F
Comment 1 Thomas Prip Vestergaard [:prip] 2012-01-05 14:59:38 PST
Created attachment 586237 [details] [diff] [review]
Bug 713822 - Simplify @media queries
Comment 2 Dão Gottwald [:dao] 2012-01-05 15:14:21 PST
Comment on attachment 586237 [details] [diff] [review]
Bug 713822 - Simplify @media queries

Great, thanks!
Comment 4 Ed Morley [:emorley] 2012-01-06 15:50:39 PST
https://hg.mozilla.org/mozilla-central/rev/f97fcb931525

Thanks prip! :-)
Comment 5 Alfred Kayser 2012-01-08 02:20:32 PST
Why was 'all and ()' used? 
Probably because of some very good reason(s). Are these reasons now no longer valid or removed?
Comment 6 Dão Gottwald [:dao] 2012-01-08 04:50:59 PST
"@media all and (...)" was probably introduced along with "@media not all and (...)", which afaik cannot be simplified.

Note You need to log in before you can comment on or make changes to this bug.