Last Comment Bug 713865 - Don't traverse XBL and XUL protos so much
: Don't traverse XBL and XUL protos so much
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: Olli Pettay [:smaug]
:
Mentors:
: 702452 (view as bug list)
Depends on: 730700
Blocks: 716598
  Show dependency treegraph
 
Reported: 2011-12-28 07:18 PST by Olli Pettay [:smaug]
Modified: 2012-02-26 10:59 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.14 KB, patch)
2011-12-28 07:18 PST, Olli Pettay [:smaug]
bent.mozilla: review+
Details | Diff | Review
up-to-date (7.52 KB, patch)
2011-12-29 06:33 PST, Olli Pettay [:smaug]
no flags Details | Diff | Review

Description Olli Pettay [:smaug] 2011-12-28 07:18:50 PST
Created attachment 584568 [details] [diff] [review]
patch
Comment 1 Andrew McCreight [:mccr8] 2011-12-28 07:33:43 PST
This is basically the same thing as bug 713865?  You can dupe that one to this one if so.
Comment 2 Andrew McCreight [:mccr8] 2011-12-28 07:35:26 PST
I guess one is a little less aggressive, because it simply extends the existing MarkInCCGeneration mechanism to these documents rather than skipping cycle collecting them altogether.
Comment 3 Olli Pettay [:smaug] 2011-12-28 07:37:46 PST
(In reply to Andrew McCreight [:mccr8] from comment #1)
> This is basically the same thing as bug 713865?

This is certainly same as bug 713865 ;)
Comment 4 Olli Pettay [:smaug] 2011-12-28 07:41:17 PST
Btw, https://tbpl.mozilla.org/?tree=Try&rev=e0dc366db91b has the patch for this bug
(and also lots of other fixes).
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-28 08:55:45 PST
Comment on attachment 584568 [details] [diff] [review]
patch

Review of attachment 584568 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!
Comment 6 Olli Pettay [:smaug] 2011-12-29 06:33:44 PST
Created attachment 584738 [details] [diff] [review]
up-to-date
Comment 7 Olli Pettay [:smaug] 2011-12-29 07:49:13 PST
https://hg.mozilla.org/mozilla-central/rev/95ccf0a6a95a
Comment 8 Olli Pettay [:smaug] 2012-01-02 15:03:15 PST
*** Bug 702452 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.