Last Comment Bug 713867 - IonMonkey: fix arrayPrototypeHasIndexedProperty
: IonMonkey: fix arrayPrototypeHasIndexedProperty
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: IonMonkey
  Show dependency treegraph
 
Reported: 2011-12-28 07:41 PST by Jan de Mooij [:jandem]
Modified: 2011-12-30 01:28 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (13.27 KB, patch)
2011-12-28 07:44 PST, Jan de Mooij [:jandem]
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2011-12-28 07:41:25 PST

    
Comment 1 Jan de Mooij [:jandem] 2011-12-28 07:44:54 PST
Created attachment 584572 [details] [diff] [review]
Patch

Move ArrayPrototypeHasIndexedProperty from JM to jsinfer and use it in Ion. The old copy in TypeOracle was incorrect (since ObjShrink landed I guess), so I'd like to have this in one place.

I can land the non-Ion part on inbound first.
Comment 2 Brian Hackett (:bhackett) 2011-12-28 07:49:45 PST
Comment on attachment 584572 [details] [diff] [review]
Patch

Review of attachment 584572 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/ion/IonBuilder.cpp
@@ +2786,5 @@
>  
>  bool
>  IonBuilder::jsop_getelem_dense()
>  {
> +    if (types::ArrayPrototypeHasIndexedProperty(cx, script))

Shouldn't this still depend on the oracle?  What if the TI oracle is not in use?

@@ +2848,5 @@
>  
>  bool
>  IonBuilder::jsop_setelem_dense()
>  {
> +    if (types::ArrayPrototypeHasIndexedProperty(cx, script))

Ditto.
Comment 3 Jan de Mooij [:jandem] 2011-12-28 08:04:05 PST
(In reply to Brian Hackett (:bhackett) from comment #2)
> 
> Shouldn't this still depend on the oracle?  What if the TI oracle is not in
> use?

Hm agreed, I will move it back to the oracle. Thanks for the quick review!
Comment 4 Jan de Mooij [:jandem] 2011-12-28 12:26:38 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/c377af7c014d

Please don't close this bug, I still have to land the IonMonkey part.
Comment 5 Marco Bonardo [::mak] 2011-12-29 03:32:59 PST
https://hg.mozilla.org/mozilla-central/rev/c377af7c014d
Comment 6 Jan de Mooij [:jandem] 2011-12-30 01:28:22 PST
http://hg.mozilla.org/projects/ionmonkey/rev/97109df486a4

Note You need to log in before you can comment on or make changes to this bug.