Last Comment Bug 713870 - IonMonkey: don't crash when scripts are invalidated during compilation
: IonMonkey: don't crash when scripts are invalidated during compilation
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: IonOSI
  Show dependency treegraph
 
Reported: 2011-12-28 08:11 PST by Jan de Mooij [:jandem] (PTO until July 31)
Modified: 2011-12-28 14:19 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.20 KB, patch)
2011-12-28 12:15 PST, David Anderson [:dvander]
jdemooij: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] (PTO until July 31) 2011-12-28 08:11:25 PST
Atm we crash since the Ion script is NULL. The easiest fix is probably to check whether the script has been invalidated after compilation, like JM.
Comment 1 David Anderson [:dvander] 2011-12-28 12:15:31 PST
Created attachment 584615 [details] [diff] [review]
fix

There is another crash after this one, but this gets rid of an assert that AutoIonContextAlloc can't nest.
Comment 2 David Anderson [:dvander] 2011-12-28 14:19:18 PST
http://hg.mozilla.org/projects/ionmonkey/rev/feb16cca7241

Note You need to log in before you can comment on or make changes to this bug.