Toolbar buttons dragged onto the stand-alone window menubar should have text-beside-icon

RESOLVED FIXED in Thunderbird 12.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

({regression})

Trunk
Thunderbird 12.0
x86
All
regression

Thunderbird Tracking Flags

(thunderbird11 fixed)

Details

Attachments

(2 attachments)

Created attachment 584617 [details]
The text is below the icon, not beside like it should be.

Steps to reproduce:

1)  Open up a stand-alone message window
2)  Customize the mail toolbar
3)  Drag a toolbar button onto the menubar

What happens?

The text for the toolbar button is below the icon.

What's expected?

The text should be beside the toolbar button.

See the attached screenshot for a look at the bug in action.
Assignee: nobody → mconley
Blocks: 644169
Status: NEW → ASSIGNED
tracking-thunderbird11: --- → ?
OS: Mac OS X → All
Keywords: regression
Created attachment 584801 [details] [diff] [review]
Patch v1

This patch makes it so that the navigation-toolbox defaults to icons-beside-text in every place it is displayed, as opposed to just messenger.xul.
Attachment #584801 - Flags: review?(sagarwal)
Comment on attachment 584801 [details] [diff] [review]
Patch v1

Cancelling review - this patch overrides the user preference to display icons above text, or icons only, and we don't want to do that.
Attachment #584801 - Flags: review?(sagarwal)
Hm - so it turns out this is harder than it sounds, because the customization code assumes we have a single toolbox as opposed to a toolbox with external toolbars that might exist within other toolboxes...
Comment on attachment 584801 [details] [diff] [review]
Patch v1

So here's what I've found out:

The customize toolbar functions in mailCore.js do not take into account the possibility that toolbars can exist outside of their toolboxes.  This means that, with this patch, switching to "text-below-icon" mode will not be obeyed by buttons in the navigation-toolbox.

The changes required by mailCore.js aren't crazy difficult, but I don't think we'd want to land them in Aurora this late in the game.

I suggest that we default to displaying text beside icons in the menubar, and then file a separate bug and fix the customize toolbar regression in a later version (TB 12, for example) in order to allow proper testing time.

Does this sound alright?
Attachment #584801 - Flags: ui-review?(bwinton)
Attachment #584801 - Flags: review?(sagarwal)
Comment on attachment 584801 [details] [diff] [review]
Patch v1

To be honest, I prefer this over text below icons in the menu bar. I'm going to let Blake make the call, though.
Attachment #584801 - Flags: review?(sagarwal) → review+
Comment on attachment 584801 [details] [diff] [review]
Patch v1

I also prefer it, and I'm not sure if we should force it to match the setting for the toolbars, since that's a very different context.

One thing I think we should definitely communicate is that this is just temporary, because of time pressure, and we may change it later to follow the toolbar setting.
Attachment #584801 - Flags: ui-review?(bwinton) → ui-review+
Attachment #584801 - Flags: approval-comm-aurora?
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/ef508aa56358
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
tracking-thunderbird11: ? → ---
Target Milestone: --- → Thunderbird 12.0
Attachment #584801 - Flags: approval-comm-aurora? → approval-comm-aurora+
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/415d430378aa
status-thunderbird11: --- → fixed
You need to log in before you can comment on or make changes to this bug.