IonMonkey: Crash in math-cordic with --ion -n

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
This test currently segfaults with LSRA.
(Assignee)

Comment 1

6 years ago
Created attachment 584642 [details] [diff] [review]
fix

The bug is a regression from bug 695075. When we re-use a Value slot for a double, we have to compute its base since it could be off by 4 bytes.
Attachment #584642 - Flags: review?(sstangl)
(Assignee)

Updated

6 years ago
Blocks: 677337
Comment on attachment 584642 [details] [diff] [review]
fix

Review of attachment 584642 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/ion/C1Spewer.cpp
@@ +55,5 @@
>  
>  bool
>  C1Spewer::init(const char *path)
>  {
> +    spewout_ = fopen(path, "a");

This seems dangerous. We should keep overwriting by default. I will not remember to periodically clear this file manually.
Attachment #584642 - Flags: review?(sstangl) → review+
(Assignee)

Comment 3

6 years ago
http://hg.mozilla.org/projects/ionmonkey/rev/fb34f17071b4 (w/ fopen change reverted)
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.