Open in New Window' for bookmarks context menu in addition to 'Open

VERIFIED DUPLICATE of bug 60581

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 60581
17 years ago
13 years ago

People

(Reporter: Claudius Gayle, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dup of 60581?)

(Reporter)

Description

17 years ago
***Overview Description: 

  It seems the behavior has recently changed in the Manage Bookmarks window
such that dbl-clicked bookmarks now load into a current window instead of a new
one. One must now guess that metakey+dblclick will open it in a new window. If
that is going to be the case I think it only appropriate that the first choice in the
context menu be 'Open in New Window' just like in a browser context menu.

I would think there is no need for plain old 'open' in the context menu anymore
since you can get that with a double-click now - just like there is no 'open' in a browser
link context menu

***Steps to Reproduce: 

1) Open Manage bookmarks.

2) Right-click on a bookmark


***Actual Results: 

'Open' is the first choice in the context menu. Choosing it loads in the current
window.

***Expected Results: 

'Open in New Window' should be the first choice instead and it should do just
that.

***Build Info: 

2001030810 builds

***Additional Information:

You can do this and bug 71051 at the same time :-)
I'm going to be filing the exact same bug for history.
(Reporter)

Comment 1

17 years ago
alecf who owns the History bug for this has noted that we'll still need the 'open' option.
Some writings by mpt have led me to agree as well. So i'm modifying this bug to reflect that
requirement. As a matter of fact, for consistency, open should be the default selection when
the context menu opens up.
Summary: 'Open in New Window' for bookmarks context menu instead of just 'Open' → 'Open in New Window' for bookmarks context menu in addition to 'Open'

Comment 2

17 years ago
Open seems to open in a new window; it's the first and default choice.  Can 
this be closed?

Comment 3

17 years ago
Double-clicking also opens in a new window. Sounds good?
Summary: 'Open in New Window' for bookmarks context menu in addition to 'Open' → Open in New Window' for bookmarks context menu in addition to 'Open

Comment 4

17 years ago
Claudius please update the status of this, thanks. still worksforme
(Reporter)

Comment 5

17 years ago
no, nothing's good. I don't know who or why these things keep changing but nothing is
consistent.

Taking some cues the browser context menu behavior (and behavior that has not changed)
here's what should happen:

Dbl-click on a bookmark finds the topmost nav window and loads it there (history does this
correctly) and this has always been the convention.

Metakey+dbl-click should open a new window

Context menu should then contain 'Open in New Window'

Although earlier I said differently, things I'm currently not sure about:
1. Should context menu contain 'Open'
2. If (1) should 'Open In New Window' be first and default?

the history vrsion of this bug is bug 71401
Summary: Open in New Window' for bookmarks context menu in addition to 'Open → 'Open in New Window' for bookmarks context menu in addition to 'Open'

Comment 6

17 years ago
Worksforme on Windows 2000 2001050915 
Summary: 'Open in New Window' for bookmarks context menu in addition to 'Open' → Open in New Window' for bookmarks context menu in addition to 'Open

Comment 7

17 years ago
OK I understand what you mean now.
Current status:
Double-click: new window
Accel + Double-click: new window
Right-click + open: new window

Indeed this is inconsistent with the history window.
Sorry for the misunderstanding. I was misled by the summary because it led me to
think that for you it was opening in the same window. Which is obviously what
should happen, but doesn't happen.
claudius: based on the summaries, this is a dup of bug 60581
Whiteboard: dup of 60581?
dup

*** This bug has been marked as a duplicate of 60581 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

16 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.