touch.facebook.com doesn't fully load

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Brion Vibber, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox 11

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a2) Gecko/20111228 Firefox/11.0a2 Fennec/11.0a2
Build ID: 20111228042019

Steps to reproduce:

go to https://touch.facebook.com and log in


Actual results:

blue bar shows, but no more.


Expected results:

full facebook touch interface should load. worked in nightlies and auroras a few days ago.

tested on amazon kindle fire, kindle 6.2.1
Component: General → Evangelism
QA Contact: general → evangelism
(Reporter)

Comment 1

7 years ago
I get the same on desktop Firefox 8.0.2 so definitely this is changes on Facebook's end.
Created attachment 584977 [details]
Fennec on left - Stock on right

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: Other → All
This WFM now with Mac desktop nightly, and I could repro before. Aaron? Reporter?
Still see this on touch.facebook.com (see attached screenshot) under Nightly (01/03) on Mobile and Mac after logging in.
(Reporter)

Comment 5

7 years ago
Doing a little testing with the current Aurora on my Galaxy Nexus, and 8.0 and latest Nightly on my Linux desktop box...

https://touch.facebook.com/ <- shows blue bar/icon and possibly "loading..." but never goes beyond

https://touch.facebook.com/home.php <- loads up a bunch of stuff, mostly works


Looks like if you go through the login process it sends you to the home.php which loads, but if you've previously logged in it doesn't.
When I'm logged in I get redirected to home.php without incident. Hmmm.

Are there errors in the console perchance?
In fact, it would be helpful to get a full web-console trace of loading it. I wonder if you have something bogus in the cache somehow, on either end.
(Reporter)

Comment 8

7 years ago
Visible in Firebug console:

  invalid range in character class

then later (possibly because of the above):

  JX.Stratcom is undefined

I can trace the invalid range to this regex:
  /;FBAV\/([\d\.-\w]+);/

Looks like the '-' should be moved to the end, after the \w, since I think it's meant to represent a literal - rather than a range. Chrome allows it without an error.
(Reporter)

Comment 9

7 years ago
Note though that I get both those errors on a successful load of https://touch.facebook.com/home.php as well...
Also possibly of interest to me: what does touch.facebook.com resolve to for you all?
No, the *web console* -- Tools->Web Developer->Web Console. Shift-ctrl-K or cmd-opt-K.
Tried again on the SII/Nexus S this morning, I see full functionality albeit the styling is quite off in Gecko -> 715515.

--
Samsung Galaxy SII (Android 2.3.4) & Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120105 Firefox/12.0a1 Fennec/12.0a1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

7 years ago
I can confirm functionality is back for me as well, Galaxy Nexus (Android 4.0.2). Yay!
(Assignee)

Updated

6 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
You need to log in before you can comment on or make changes to this bug.