Build error: undefined reference to calDateTime::PreCreatePrototype

RESOLVED DUPLICATE of bug 713633

Status

RESOLVED DUPLICATE of bug 713633
7 years ago
7 years ago

People

(Reporter: ewong, Unassigned)

Tracking

Lightning 1.4

Details

(Reporter)

Comment 1

7 years ago
make[6]: *** [libcalbasecomps.so] Error 1
make[6]: Leaving directory `/buildbot/comm-central-linux/build/objdir-tb/calendar/base/build'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/buildbot/comm-central-linux/build/objdir-tb/calendar/base'
make[4]: Leaving directory `/buildbot/comm-central-linux/build/objdir-tb/calendar/lightning'
make[4]: *** [libs] Error 2
make[3]: *** [libs_tier_app] Error 2
make[3]: Leaving directory `/buildbot/comm-central-linux/build/objdir-tb'
make[2]: *** [tier_app] Error 2
make[2]: Leaving directory `/buildbot/comm-central-linux/build/objdir-tb'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/buildbot/comm-central-linux/build/objdir-tb'
make: *** [build] Error 2
(Reporter)

Comment 2

7 years ago
OSX

/tools/python/bin/python2.6 /builds/slave/comm-central-macosx64/build/mozilla/config/pythonpath.py -I../../../mozilla/config /builds/slave/comm-central-macosx64/build/mozilla/config/expandlibs_exec.py --uselist --  /opt/local/bin/ccache /usr/bin/g++-4.2 -arch i386  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fno-common -fshort-wchar -pthread -DNO_X11  -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer -fPIC  -o libcalbasecomps.dylib  calBaseModule.o     -framework Cocoa -lobjc  -framework ExceptionHandling -Wl,-executable_path,/builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/bin -Wl,-dead_strip /builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/lib/libmozutils.a  ../../../calendar/base/src/libcalbase_s.a ../../../calendar/libical/src/libical/libmozical.a  -L/builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/bin -lxpcom -lmozalloc /builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/bin/XUL -L../../../mozilla/dist/bin -L../../../mozilla/dist/lib  `/builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/sdk/bin/nspr-config --prefix=/builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist --libdir=/builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/lib --libs` /builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/lib/libxpcomglue_s.a -L/builds/slave/comm-central-macosx64/build/objdir-tb/i386/mozilla/dist/bin -lxpcom -lmozalloc  -Wl,-exported_symbols_list -Wl,/builds/slave/comm-central-macosx64/build/mozilla/build/unix/gnu-ld-scripts/components-export-list -bundle    
Undefined symbols:
  "calDateTime::PreCreatePrototype(JSContext*, JSObject*, JSObject**)", referenced from:
      vtable for calDateTimein calDateTime.o
  "non-virtual thunk to calDateTime::PreCreatePrototype(JSContext*, JSObject*, JSObject**)", referenced from:
      vtable for calDateTimein calDateTime.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[7]: *** [libcalbasecomps.dylib] Error 1
make[6]: *** [libs] Error 2
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_app] Error 2
make[3]: *** [tier_app] Error 2
make[2]: *** [default] Error 2
make[1]: *** [build] Error 2
make: *** [build] Error 2
program finished with exit code 2
(Reporter)

Comment 3

7 years ago
WINNT 5.2 comm-central lightning build on 2011/12/28 16:47:21

d:/mozilla-build/python25/python2.5.exe /e/buildbot/comm-central-win32/build/mozilla/config/pythonpath.py -I../../../mozilla/config /e/buildbot/comm-central-win32/build/mozilla/config/expandlibs_exec.py --uselist -- link -NOLOGO -DLL -OUT:calbasecomps.dll -PDB:calbasecomps.pdb -SUBSYSTEM:WINDOWS  calBaseModule.obj    ./module.res -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH  -DEBUG -DEBUGTYPE:CV -DEBUG -OPT:REF   -IMPLIB:fake.lib -LIBPATH:../../../mozilla/dist/lib -NODEFAULTLIB:msvcrt -NODEFAULTLIB:msvcrtd -NODEFAULTLIB:msvcprt -NODEFAULTLIB:msvcprtd -DEFAULTLIB:mozcrt  ../../../calendar/base/src/calbase_s.lib ../../../calendar/libical/src/libical/mozical.lib  e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/mozjs.lib   e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/nspr4.lib e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/plc4.lib e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/plds4.lib  e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/xpcomglue_s.lib e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/xpcom.lib e:/buildbot/comm-central-win32/build/objdir-tb/mozilla/dist/lib/mozalloc.lib   kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib   
   Creating library fake.lib and object fake.exp
LINK : warning LNK4098: defaultlib 'LIBCMT' conflicts with use of other libs; use /NODEFAULTLIB:library
calDateTime.obj : error LNK2001: unresolved external symbol "public: virtual unsigned int __stdcall calDateTime::PreCreatePrototype(struct JSContext *,struct JSObject *,struct JSObject * *)" (?PreCreatePrototype@calDateTime@@UAGIPAUJSContext@@PAUJSObject@@PAPAU3@@Z)
calbasecomps.dll : fatal error LNK1120: 1 unresolved externals
make[6]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb/calendar/base/build'
make[5]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb/calendar/base'
make[4]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb/calendar/lightning'
make[6]: *** [calbasecomps.dll] Error 96
make[5]: *** [libs] Error 2
make[4]: *** [libs] Error 2
make[3]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb'
make[2]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb'
make[1]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb'
make[3]: *** [libs_tier_app] Error 2
make[2]: *** [tier_app] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2
program finished with exit code 2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713633
You need to log in before you can comment on or make changes to this bug.