Open Bug 714106 Opened 12 years ago Updated 1 year ago

Corrupt downloads when saving to router network share with Win 7


(Firefox :: General, defect)

10 Branch
Windows 7





(Reporter: rickau, Unassigned)


User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20111228055358

Steps to reproduce:

Download any file larger than ~15MB to a remote share connected to netgear router.

Actual results:

The file is corrupted after download.  I test this by downloading a large zip to the share and running a 'test' on the zip file to be sure it downloaded correctly. I performed a diff on a good file and a corrupted file with a hex editor, and somewhere in the middle of the corrupt file a string of zeros had been inserted.

I've tried a new router, also netgear, with the same results. I don't see this issue with firefox downloading to shares on windows or linux pcs.

This issue only seems to affect win7 (32 bit and 64 bit), not XP. I first saw this issue with 5.0b1, and thought it would be eventually fixed. This issue still affects 9.0.1 and 10.0beta2. I don't see this issue with internet explorer, chrome, or firefox 3.6

Expected results:

The file should download correctly to the share.

I do not see the issue with firefox 4.0 or 3.6.25. Firefox 5.0b1 was the start of the corruption issue.
I performed some other tests.
I tried downloading to my network share:

The file is ok and uncorrupted.

but downloading this way is corrupted, every time.
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.