Update app.support.baseURL to point to support.mozilla.org

RESOLVED FIXED in Firefox 13

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: jsocol, Assigned: kbrosnan)

Tracking

Firefox 12
Firefox 13
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We just moved support.mozilla.com->support.mozilla.org. The app.support.baseURL preference should be updated to avoid an extra redirect for users.

Also, in bug 714083, zpao mentioned that mobile is using sumo/mobile as its baseURL. It should use the same baseURL format as desktop Firefox, if possible, but with s/firefox/mobile/ (or something else distinct) in the first slot. SUMO is built to handle redirects properly from multiple products.

That is, the correct baseURL should be something like

http://support.mozilla.org/1/mobile/%VERSION%/%OS%/%LOCALE%/

If tablet UI can be further distinguished from phones, that'd be even more awesome.

And sorry if this is in the wrong product/component, I guessed.
Assignee: nobody → kbrosnan
Attachment #586920 - Flags: review?(mbrubeck)
Attachment #586920 - Flags: review?(mbrubeck) → review+
Why does mobile link directly to articles instead of using app.support.baseURL as a base URL?

It's really better if you don't link directly to articles as we have a system in place to allow us to take support topics (how Desktop does it) and send them to the right article, which lets us change the target if necessary without changing the code in the browser.
Duplicate of this bug: 723995
It looks like this was fixed in bug 709339:
https://hg.mozilla.org/mozilla-central/rev/8fce4fbe7eb7
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 709339
Resolution: --- → FIXED
(In reply to Matt Brubeck (:mbrubeck) from comment #4)
> It looks like this was fixed in bug 709339:
> https://hg.mozilla.org/mozilla-central/rev/8fce4fbe7eb7

I only see support.mozilla.org for sync-related constants. That's not all of the usage is it?
(In reply to Paul O'Shannessy [:zpao] from comment #5)
> > It looks like this was fixed in bug 709339:
> > https://hg.mozilla.org/mozilla-central/rev/8fce4fbe7eb7
> 
> I only see support.mozilla.org for sync-related constants. That's not all of
> the usage is it?

Oops, you're right.  Part of this patch is still needed.  I'll push it to inbound.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/integration/mozilla-inbound/rev/c8ef5cfb9a57

This patch changes a URL in mobile/locales/generic/profile/bookmarks.json.in.  Is it possible to land this on Aurora/Beta without breaking string freeze?  (This patch isn't really needed on Aurora or Beta, so we can choose not to backport it there.)
Status: REOPENED → ASSIGNED
Target Milestone: --- → Firefox 13
https://hg.mozilla.org/mozilla-central/rev/c8ef5cfb9a57
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
The bookmarks.json.in change doesn't matter to l10n. Doesn't imply that it should not just walk the channels.

I suspect that we're not changing the urls in existing profiles, fwiw, just in new profiles.
You need to log in before you can comment on or make changes to this bug.