If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When javascript is disabled XUL still crashes Mozilla with "access violation"

RESOLVED FIXED in mozilla0.9

Status

()

Core
XUL
P2
normal
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: georgi - hopefully not receiving bugspam, Assigned: Chris Waterson)

Tracking

({crash})

Trunk
mozilla0.9
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

When javascript is disabled XUL still crashes Mozilla with "access violation".
The following XUL crashes latest mozilla build if JS is disabled.
-----------------------------------------------------------------------
<?xml version="1.0"?> 
<!DOCTYPE window [
]>
<window id="main-window" xmlns:html="http://www.w3.org/TR/REC-html40"
  xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
>
<html:script src="http://www.guninski.com/js.js" id="scr1"></html:script>
<html:h3>123456
</html:h3>
</window>
-----------------------------------------------------------------------

The call stack (from a not very recent debug build) is:
------------------------------------------------------------
JS_GetPrivate(JSContext * 0x03477b40, JSObject * 0x00000000) line 1850 + 3 bytes
nsJSContext::ExecuteScript(nsJSContext * const 0x03476340, void * 0x00000000, 
void * 0x01156140, basic_nsAWritableString<unsigned short> * 0x00000000, int * 
0x00000000) line 748 + 21 bytes
nsXULDocument::ExecuteScript(JSObject * 0x00000000) line 5446 + 33 bytes
nsXULDocument::OnStreamComplete(nsXULDocument * const 0x03a6749c, 
nsIStreamLoader * 0x03a57810, nsISupports * 0x00000000, unsigned int 0, unsigned 
int 40, const char * 0x03a25f40) line 5394 + 18 bytes
nsStreamLoader::OnStopRequest(nsStreamLoader * const 0x03a57814, nsIChannel * 
0x03a51b50, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x100ae040 gCommonEmptyBuffer) line 121 + 78 bytes
nsHTTPFinalListener::OnStopRequest(nsHTTPFinalListener * const 0x03a539c0, 
nsIChannel * 0x03a51b50, nsISupports * 0x00000000, unsigned int 0, const 
unsigned short * 0x100ae040 gCommonEmptyBuffer) line 1180 + 42 bytes
InterceptStreamListener::OnStopRequest(InterceptStreamListener * const 
0x03a21fd0, nsIChannel * 0x03a51b50, nsISupports * 0x00000000, unsigned int 0, 
const unsigned short * 0x100ae040 gCommonEmptyBuffer) line 1212
nsHTTPChannel::ResponseCompleted(nsIStreamListener * 0x03a21fd0, unsigned int 0, 
const unsigned short * 0x100ae040 gCommonEmptyBuffer) line 1929 + 42 bytes
nsHTTPServerListener::OnStopRequest(nsHTTPServerListener * const 0x03a45b60, 
nsIChannel * 0x03a515c4, nsISupports * 0x03a51b50, unsigned int 0, const 
unsigned short * 0x100ae040 gCommonEmptyBuffer) line 733
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x03a22b80) line 
177 + 67 bytes
nsStreamObserverEvent::HandlePLEvent(PLEvent * 0x03a22b84) line 78
PL_HandleEvent(PLEvent * 0x03a22b84) line 576 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0056a950) line 509 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00750534, unsigned int 49401, unsigned int 0, 
long 5679440) line 1054 + 9 bytes
USER32! 77e148dc()
USER32! 77e14aa7()
USER32! 77e266fd()
nsAppShellService::Run(nsAppShellService * const 0x005828c0) line 408
main1(int 1, char * * 0x004c43b0, nsISupports * 0x00000000) line 978 + 32 bytes
main(int 1, char * * 0x004c43b0) line 1272 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 6
------------------------------------------------------------

Comment 1

17 years ago
->hyatt
Assignee: trudelle → hyatt

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
*** Bug 49600 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
-->waterson
Assignee: hyatt → waterson
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 4

17 years ago
Created attachment 27837 [details]
test as text/xul attachment
(Assignee)

Comment 5

17 years ago
Created attachment 27847 [details] [diff] [review]
always check script object from CompileScript
(Assignee)

Comment 6

17 years ago
mitch, brendan: more of the same with respect to the disabled JS causing XUL to
crash. Could you guys love me up with some r=?
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: crash
(Assignee)

Updated

17 years ago
Priority: -- → P2
Target Milestone: mozilla1.0 → mozilla0.9
sr=brendan@mozilla.org, but the bug'll larn 'em for daring to turn JS off!

/be
looks good, r=mstoltz.
(Assignee)

Updated

17 years ago
Keywords: patch
(Assignee)

Comment 9

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.