Mac attachment Unresponsive script failure finds chrome path 8.0 9.0.1

RESOLVED DUPLICATE of bug 476541

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 476541
7 years ago
3 years ago

People

(Reporter: Bob McBeth, Unassigned)

Tracking

9 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.51.22 (KHTML, like Gecko) Version/5.1.1 Safari/534.51.22

Steps to reproduce:

Tried to add 3 attachments to a message. The first time (v8.0), a script failure pop-up hung Thunderbird -- "Warning: Unresponsive script" -- presumably because  the warning popped up after the filesystem dialog. Updated to v9.0.1. This time the script failure pop-up came first. I selected the choice of "Continue" and the script completed with all 3 attachments showing in the attachment pane. Now the attachment procedure seems to work without script error.


Actual results:

First time (v8.0), I had to kill the process because the system dialog and Thunderbird were deadlocked. The second time (v9.0.1) I selected "Continue" instead of "Stop script". I did not reboot my Mac. The warning was:

Warning: Unresponsive script

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://messenger/content/mailWidgets.xml:0

Note, that Chrome was running in the background.


Expected results:

The system dialog should have allowed selecting the files to attach and no script problems should have occurred. I'm not sure everyone would have taken the risk of completing the script by continuing. The attachment process now works without error. Chrome is still running in the background.
(Reporter)

Comment 1

7 years ago
MacOs 10.6.8 (Snow Leopard)

Comment 2

7 years ago
(In reply to Bob McBeth from comment #0)
Do you have addons installed? If yes, try composing in safe mode: http://support.mozillamessaging.com/en-US/kb/Safe-Mode

Updated

6 years ago
Summary: Mac attachment script failure finds chrome path 8.0 9.0.1 → Mac attachment Unresponsive script failure finds chrome path 8.0 9.0.1
Whiteboard: dupeme

Updated

6 years ago
Component: General → Untriaged

Updated

3 years ago
Component: Untriaged → Mail Window Front End

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.