Opening new tabs in the background suppresses rendering and it never unsuppresses

VERIFIED FIXED in Firefox 12

Status

()

defect
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: pcwalton, Assigned: pcwalton)

Tracking

unspecified
Firefox 12
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox11 unaffected, firefox12 fixed, firefox13 verified)

Details

(Whiteboard: [not-fennec-11])

Attachments

(1 attachment)

My patches for bug 709492 made tabs opened in the background no longer appear. Sorry. Here's a fix.
Attachment #584918 - Flags: review?(bugmail.mozilla)
Comment on attachment 584918 [details] [diff] [review]
Proposed patch.

Review of attachment 584918 [details] [diff] [review]:
-----------------------------------------------------------------

Good thing you caught it early :)
Attachment #584918 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/d4c526ba5343
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Patrick, please request aurora approval
Comment on attachment 584918 [details] [diff] [review]
Proposed patch.

[Triage Comment]
Needed on beta since it fixes a regression caused by bug 709492 which is on beta
Attachment #584918 - Flags: approval-mozilla-beta+
So this patch was actually backed out as part of the backout of bug 709492 (see comment 61 on that bug), and the modified re-landed version didn't need this patch. So it doesn't need to be uplifted anywhere.
No longer blocks: 709492
Depends on: 709492
Comment on attachment 584918 [details] [diff] [review]
Proposed patch.

Removing beta approval since this doesn't need to be uplifted.
Attachment #584918 - Flags: approval-mozilla-beta+
This is only about the tabs opened in background that were not appearing or I should look at some other bad behavior also in order to verify it?
Yeah, this is only about tabs opened in background. STR would be something like:

1) Open some page
2) Long tap on a link, open new tab
3) Wait a while for the background tab to finish loading
4) Switch to the new tab

If the new tab shows up normally then that's good. You can also try without step 3, so switching tabs while it's still loading. That should work as well.
Verified on:
Nightly Fennec 13.0a1 (2012-03-04)
Device: HTC Desire Z
OS: Android 2.3.3

The new tab shows up normally.
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.