[build error] [ff9.0.1] The cacheFlush support is missing on this platform.

RESOLVED DUPLICATE of bug 703534

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 703534
6 years ago
6 years ago

People

(Reporter: Douglas, Unassigned)

Tracking

9 Branch
PowerPC
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux ppc64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 Iceweasel/9.0.1
Build ID: 20111222102119

Steps to reproduce:

I'm trying to build Firefox 9.0.1. I' using the following .mozconfig:

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1

ac_add_options --enable-postscript
ac_add_options --enable-strip
ac_add_options --prefix=/usr
ac_add_options --sysconfdir=/etc
ac_add_options --mandir=/usr/share/man
ac_add_options --with-default-mozilla-five-home=/usr/lib
ac_add_options --with-pthreads
#ac_add_options --with-system-png
ac_add_options --disable-calendar
ac_add_options --disable-chatzilla
ac_add_options --disable-composer
ac_add_options --disable-crashreporter
ac_add_options --disable-debug
ac_add_options --disable-elf-dynstr-gc
ac_add_options --disable-installer
ac_add_options --disable-ipc
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --disable-mochitest 
ac_add_options --disable-accessibility
ac_add_options --disable-libnotify
ac_add_options --disable-negotiateauth
ac_add_options --disable-official-branding
ac_add_options --disable-profilesharing
ac_add_options --disable-system-cairo 
ac_add_options --disable-tests
ac_add_options --disable-toolkit-qt
ac_add_options --disable-updater
ac_add_options --disable-xinerama
ac_add_options --disable-xprint
ac_add_options --disable-necko-wifi
ac_add_options --enable-application=browser
ac_add_options --enable-crypto
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --enable-extensions="default spellcheck"
ac_add_options --enable-freetype2
ac_add_options --enable-optimize="-pipe -O3"
ac_add_options --enable-pango
ac_add_options --enable-strip
ac_add_options --enable-svg
ac_add_options --enable-svg-renderer=cairo
ac_add_options --enable-toolkit-cairo-gtk2
ac_add_options --enable-xft
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib


Actual results:

I got these error messages:

jsoplengen.cpp
jsalloc.cpp
jsanalyze.cpp
jsapi.cpp
jsarena.cpp
jsarray.cpp
jsatom.cpp
jsbool.cpp
jsclone.cpp
jscntxt.cpp
jscompartment.cpp
In file included from /home/username/build-farm/_BIGSYSTEM/icecat-v9.0.1.builddir/js/src/jscompartment.cpp:53:0:
/home/username/build-farm/_BIGSYSTEM/icecat-v9.0.1.builddir/js/src/assembler/jit/ExecutableAllocator.h:440:6: error: #error "The cacheFlush support is missing on this platform."
 
In the directory  /home/username/build-farm/_BIGSYSTEM/icecat-v9.0.1.builddir/js/src
The following command failed to execute properly:
c++ -o jscompartment.o -c -fvisibility=hidden -DOSTYPE="Linux3.1" -DOSARCH=Linux -DEXPORT_JS_API -DIMPL_MFBT -DJS_HAS_CTYPES -DDLL_PREFIX="lib" -DDLL_SUFFIX=".so" -Ictypes/libffi/include -I. -I. -I. -I./../../dist/include -I./../../dist/include/nsprpub -I/home/username/build-farm/_BIGSYSTEM/icecat-v9.0.1.builddir/dist/include/nspr -I. -I./assembler -I./yarr -fPIC -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -pthread -pipe -DNDEBUG -DTRIMMED -g -pipe -O3 -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/jscompartment.pp /home/username/build-farm/_BIGSYSTEM/icecat-v9.0.1.builddir/js/src/jscompartment.cpp
make[3]: *** [jscompartment.o] Error 1
make[2]: *** [libs_tier_js] Error 2
make[1]: *** [tier_js] Error 2
make: *** [default] Error 2
ERROR: 'make' error. Abort.


Expected results:

Normal build.
(Reporter)

Comment 1

6 years ago
Oh, I almost forgot. The platform I'm building on and for is GNU/Linux @ powerpc64.
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Hardware: Other → PowerPC
Original reporter had build success using the fix from bug 703534.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703534
You need to log in before you can comment on or make changes to this bug.