Not enough memory warning

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: unesto, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 584991 [details]
Close programs to prevent loss of information. You do not have enough memory. Save the files and quit the following programs: Nightly.

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20111230 Firefox/12.0a1
Build ID: 20111230031151

Steps to reproduce:

Program was running on background when I was using Eclipse.


Actual results:

Windows showed warning in attachment and Nightly crashed, when I later attempted to watch video. Nightly was using around 500 000 kB, but I have 6GB of memory...


Expected results:

Nothing? :) I should watch video...

Comment 1

7 years ago
What is the issue? the crash? the message? 

How much memory was available when Nightly crashed?

Please provide a crash id or stacktrace -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Component: General → Untriaged
QA Contact: general → untriaged
(Reporter)

Comment 2

7 years ago
Sorry, but I can't find crash ID. I type: about:crash, there are 4 crashes, but nothing from yesterday.

What is the issue? the crash? the message?
I was writing some java app and Nightly was running on back with several tabs, suddenly message (in attachment) appeared. (closed warning window)
Then I try continue... visit page with video: mozilla.org/projects/firefox/prerelease.html.

I can provide only from MS:
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-Resource-Exhaustion-Detector" Guid="{9988748E-C2E8-4054-85F6-0C3E1CAD2470}" /> 
  <EventID>2004</EventID> 
  <Version>0</Version> 
  <Level>3</Level> 
  <Task>3</Task> 
  <Opcode>33</Opcode> 
  <Keywords>0x8000000020000000</Keywords> 
  <TimeCreated SystemTime="2011-12-30T17:32:14.182656500Z" /> 
  <EventRecordID>277810</EventRecordID> 
  <Correlation ActivityID="{0A049073-07F6-4628-A80E-C3A886A1B4BD}" /> 
  <Execution ProcessID="1100" ThreadID="8348" /> 
  <Channel>System</Channel> 
<Security UserID="S-1-5-18" /> 
  </System>
- <UserData>
- <MemoryExhaustionInfo xmlns:auto-ns2="http://schemas.microsoft.com/win/2004/08/events" xmlns="http://www.microsoft.com/Windows/Resource/Exhaustion/Detector/Events">
- <SystemInfo>
  <SystemCommitLimit>25549217792</SystemCommitLimit> 
  <SystemCommitCharge>25295351808</SystemCommitCharge> 
  <ProcessCommitCharge>2456690688</ProcessCommitCharge> 
  <PagedPoolUsage>390459392</PagedPoolUsage> 
  <PhysicalMemorySize>6387777536</PhysicalMemorySize> 
  <PhysicalMemoryUsage>3095080960</PhysicalMemoryUsage> 
  <NonPagedPoolUsage>144912384</NonPagedPoolUsage> 
  <Processes>92</Processes> 
  </SystemInfo>
- <ProcessInfo>
- <Process_1>
  <Name>firefox.exe</Name> 
  <ID>280</ID> 
  <CreationTime>2011-12-30T11:45:06.519990000Z</CreationTime> 
  <CommitCharge>709070848</CommitCharge> 
  <HandleCount>695</HandleCount> 
  <Version>12.0.0.4380</Version> 
  <TypeInfo>201</TypeInfo> 
  </Process_1>
- <Process_2>
  <Name>eclipse.exe</Name> 
  <ID>2764</ID> 
  <CreationTime>2011-12-30T15:05:07.335789700Z</CreationTime> 
  <CommitCharge>213315584</CommitCharge> 
  <HandleCount>663</HandleCount> 
  <Version>0.0.0.0</Version> 
  <TypeInfo>210</TypeInfo> 
  </Process_2>
- <Process_3>
  <Name>svchost.exe</Name> 
  <ID>1100</ID> 
  <CreationTime>2011-12-30T09:45:41.112431000Z</CreationTime> 
  <CommitCharge>162414592</CommitCharge> 
  <HandleCount>643</HandleCount> 
  <Version>6.1.7600.16385</Version> 
  <TypeInfo>33859</TypeInfo> 
  </Process_3>
- <Process_4>
  <Name>CCC.exe</Name> 
  <ID>5856</ID> 
  <CreationTime>2011-12-30T09:47:08.948582800Z</CreationTime> 
  <CommitCharge>131895296</CommitCharge> 
  <HandleCount>1081</HandleCount> 
  <Version>3.5.0.0</Version> 
  <TypeInfo>152</TypeInfo> 
  </Process_4>
- <Process_5>
  <Name /> 
  <ID>0</ID> 
  <CreationTime>1601-01-01T00:00:00.000000000Z</CreationTime> 
  <CommitCharge>0</CommitCharge> 
  <HandleCount>0</HandleCount> 
  <Version>0.0.0.0</Version> 
  <TypeInfo>0</TypeInfo> 
  </Process_5>
- <Process_6>
  <Name /> 
  <ID>0</ID> 
  <CreationTime>1601-01-01T00:00:00.000000000Z</CreationTime> 
  <CommitCharge>0</CommitCharge> 
  <HandleCount>0</HandleCount> 
  <Version>0.0.0.0</Version> 
  <TypeInfo>0</TypeInfo> 
  </Process_6>
  </ProcessInfo>
- <PagedPoolInfo>
- <Tag_1>
  <Name>Toke</Name> 
  <PoolUsed>93554192</PoolUsed> 
  </Tag_1>
- <Tag_2>
  <Name>CM31</Name> 
  <PoolUsed>85938176</PoolUsed> 
  </Tag_2>
- <Tag_3>
  <Name>MmSt</Name> 
  <PoolUsed>49508496</PoolUsed> 
  </Tag_3>
  </PagedPoolInfo>
- <NonPagedPoolInfo>
- <Tag_1>
  <Name>SpDN</Name> 
  <PoolUsed>25942656</PoolUsed> 
  </Tag_1>
- <Tag_2>
  <Name>@GMM</Name> 
  <PoolUsed>15440784</PoolUsed> 
  </Tag_2>
- <Tag_3>
  <Name>Rptr</Name> 
  <PoolUsed>15308624</PoolUsed> 
  </Tag_3>
  </NonPagedPoolInfo>
- <ExhaustionEventInfo>
  <Time>2011-12-30T17:32:13.449419400Z</Time> 
  </ExhaustionEventInfo>
  </MemoryExhaustionInfo>
  </UserData>
  </Event>

Comment 3

7 years ago
The report seems to imply Firefox was using 700MB or memory. That is not much to cause a problem. Why Windows decided to kill Firefox to free memory is not known, but maybe it can't be influenced. Did you choose to 'Close the program' (Nightly) or 'Cancel'? Even if Cancel, Windows could kill Firefox by itself. So there may not be a crash from Firefox.
Eclipse isn't taking to much RAM too (200MB). So I don't know why Windows does this, you need to watch it again and see which processes are taking the RAM.
Hardware: x86 → x86_64
(Reporter)

Comment 4

7 years ago
I selected "Cancel" ("Storno") and little while from it, Nightly crashed... However I can't find crash report. (about:crashes)... (Maybe I closed window "send crash report", and I don't remember it...)

Comment 5

7 years ago
I don't think firefox crashed here or that firefox is at fault.

*windows'* memory usage was simply too high, no doubt caused by multiple programs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 6

5 years ago
There is also the fact that Firefox' memory usage was (is) too high.
You need to log in before you can comment on or make changes to this bug.