selection style doesn't match explorer selection style making deselected items less obvious

RESOLVED DUPLICATE of bug 686959

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 686959
6 years ago
6 years ago

People

(Reporter: asa, Assigned: Paenglab)

Tracking

12 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 585007 [details]
see the deselected message in the middle still has a blue border

If you select a batch of messages, click one, move down 5 or 6 and shift-click another one, and then you go to de-select one of the messages in the middle, the background color changes to de-selected but the selection border remains. This makes it hard to tell that you've actually deselected that message.
(Reporter)

Comment 1

6 years ago
tested with latest nightly build on win7 with three vertical panels view.
(Assignee)

Comment 2

6 years ago
Created attachment 585040 [details] [diff] [review]
Remove the border on deselect

With removing this definition the border is removed when the treechildren is deselected. I saw no negative effects without this definition.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #585040 - Flags: review?(bwinton)

Comment 3

6 years ago
This *definitely* shouldn't be removed. It's the focus-ring for the message, without which you'd have no idea what row is currently focused in the tree. Granted, we need to fix the colors a bit so that you can tell which row is focused when it's *selected* too, but that's bug 686959.

Perhaps more importantly, the behavior described in comment 0 is exactly what happens in Windows Explorer, which is the basis of the theming used for the message list.
(Reporter)

Comment 4

6 years ago
You are correct, I'm updating the summary. The style does not match explorer. The borders are heavier, doubled up, and darker. The gradient is wrong too.
Summary: de-selecting a message doesn't adjust style completely → selection style doesn't match explorer selection style making deselected items less obvious
(Reporter)

Comment 5

6 years ago
Created attachment 585055 [details]
selection doesn't match system

here's a comparison. we need to match the system. not matching the system is why this felt so odd to me in thunderbird.
Attachment #585040 - Attachment is obsolete: true
Attachment #585040 - Flags: review?(bwinton)
(Reporter)

Updated

6 years ago
Attachment #585007 - Attachment is obsolete: true
(Reporter)

Comment 6

6 years ago
actually, just resolving as dupe.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686959

Comment 7

6 years ago
The doubled borders are going to be tough to fix, since we're limited by the XUL tree implementation. A while back, I spent an afternoon or two trying to figure out a way to avoid the doubled borders, but it didn't work. Probably the only (sane) way to solve this would be to implement the CSS border-collapse rule on XUL trees, which is beyond my ken.

For the color values, there's attachment 562970 [details], which shows all the possible selection states used in Explorer.
You need to log in before you can comment on or make changes to this bug.