[ACR] Compatible-by-default exceptions can no longer be force-enabled

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: dave, Unassigned)

Tracking

ACR-1.*

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

- ACR is already installed, as well as my Dock Progress extension: https://addons.mozilla.org/en-US/firefox/addon/dock-progress/
- I upgraded to Aurora 11.0a.



Actual results:

Dock Progress was disabled, and marked as incompatible. This happens even with compatible-by-default, since the extension contains a binary component.


Expected results:

ACR should have provided some way to disable compatibility checking, so the extension could be tested.

A workaround is to manually add extensions.checkCompatibility.11.0a => false.
ACR is no longer disabling compatibility checking for DTC-enabled builds; if an add-on is not marked as compatible, there's a good reason and users who insist on overriding that will need to do so on their own.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.