Last Comment Bug 714418 - Remove nsIXPCScriptable::DONT_SHARE_PROTOTYPE (and make all XPCWNProtos be shared)
: Remove nsIXPCScriptable::DONT_SHARE_PROTOTYPE (and make all XPCWNProtos be sh...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Bill McCloskey (:billm)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-30 21:10 PST by Bill McCloskey (:billm)
Modified: 2012-01-05 08:47 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (23.23 KB, patch)
2011-12-30 21:10 PST, Bill McCloskey (:billm)
bobbyholley: review+
mrbkap: superreview+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2011-12-30 21:10:56 PST
Created attachment 585110 [details] [diff] [review]
patch

We appear to support singleton XPCWrappedNativeProtos, but I don't think this is ever used. I checked MXR and I added an assertion and got a green on try. So this should be safe.

May our invariants grow stronger each day!

I'd also like to get rid of these uppercase variable names. They're awful.
Comment 1 Bobby Holley (:bholley) (busy with Stylo) 2012-01-02 11:43:27 PST
Comment on attachment 585110 [details] [diff] [review]
patch

Looks good!

This needs sr, I think. I'm guessing we don't need to rev the IDL here since it's just a constant, but blake would know for sure. Flagging him for sr.
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2012-01-02 11:44:39 PST
(In reply to Bill McCloskey (:billm) from comment #0) 
> I'd also like to get rid of these uppercase variable names. They're awful.

I'd guess that they'd be going away with the new DOM bindings, so it's probably better to just wait. :-)
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-01-02 11:50:48 PST
No, removing enums is binary compatible.
Comment 5 Marco Bonardo [::mak] 2012-01-05 08:47:28 PST
https://hg.mozilla.org/mozilla-central/rev/1dc627b6158d

Note You need to log in before you can comment on or make changes to this bug.