nsWebMReader::ReadMetadata reads preferences off the main thread

RESOLVED FIXED in Firefox 11

Status

()

Core
Audio/Video
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: khuey, Assigned: khuey)

Tracking

unspecified
mozilla12
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox9 wontfix, firefox10 wontfix, firefox11 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Created attachment 585137 [details] [diff] [review]
Patch

Which is not allowed.

I'm not sure if not setting mInfo.mStereoMode if the preference getter failed was intentional ... I'm going to guess it wasn't.
Attachment #585137 - Flags: review?(roc)
Blocks: 619487
Attachment #585137 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/51965075faf5
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
Comment on attachment 585137 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): Bug 584259
User impact if declined: Potentially rare crashes when using WebM <video>
Testing completed (on m-c, etc.): None, but it's obvious from code inspection what's wrong here.
Risk to taking this patch (and alternatives if risky): Fairly low.
Attachment #585137 - Flags: approval-mozilla-beta?
Attachment #585137 - Flags: approval-mozilla-aurora?

Comment 3

6 years ago
Comment on attachment 585137 [details] [diff] [review]
Patch

[Triage Comment]
Let's take this on Aurora given the low risk nature of the fix, but let's only take on beta if we find that significant crash reports (right now we think it's rare).
Attachment #585137 - Flags: approval-mozilla-beta?
Attachment #585137 - Flags: approval-mozilla-beta-
Attachment #585137 - Flags: approval-mozilla-aurora?
Attachment #585137 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ea508b336fed
status-firefox10: --- → affected
status-firefox11: --- → fixed
status-firefox9: --- → wontfix
Whiteboard: [qa-]
Depends on: 725152
status-firefox10: affected → wontfix
Depends on: 744063
No longer depends on: 744063
You need to log in before you can comment on or make changes to this bug.