Last Comment Bug 714510 - Viewpickerlabel has a white background on normal toolbars
: Viewpickerlabel has a white background on normal toolbars
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: 12 Branch
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 12.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
: 715508 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-01 05:51 PST by Richard Marti (:Paenglab)
Modified: 2012-01-12 07:03 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Screenshot showing the issue (1.88 KB, image/png)
2012-01-01 05:51 PST, Richard Marti (:Paenglab)
no flags Details
Use the background only on tabbar-toolbar (511 bytes, patch)
2012-01-01 05:55 PST, Richard Marti (:Paenglab)
mconley: review+
mconley: ui‑review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Richard Marti (:Paenglab) 2012-01-01 05:51:38 PST
Created attachment 585194 [details]
Screenshot showing the issue

The viewpickerlabel has a white background to be better readable. Now with the tabs on top only the tabbar-toolbar is transparent. On other toolbars this background looks odd.
Comment 1 Richard Marti (:Paenglab) 2012-01-01 05:55:20 PST
Created attachment 585195 [details] [diff] [review]
Use the background only on tabbar-toolbar

This patch changes to show the white background only on the tabbar-toolbar. This is now the only transparent toolbar.
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-01-04 10:44:33 PST
Comment on attachment 585195 [details] [diff] [review]
Use the background only on tabbar-toolbar

Fixes the problem for me, and the code looks good.  Thanks!

-Mike
Comment 3 Richard Marti (:Paenglab) 2012-01-04 10:56:33 PST
Comment on attachment 585195 [details] [diff] [review]
Use the background only on tabbar-toolbar

Asking for approval because the same issue is on aurora
Comment 4 Richard Marti (:Paenglab) 2012-01-05 09:42:23 PST
*** Bug 715508 has been marked as a duplicate of this bug. ***
Comment 5 Mike Conley (:mconley) - (needinfo me!) 2012-01-05 13:58:49 PST
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/3d61a0034ce1
Comment 6 Mike Conley (:mconley) - (needinfo me!) 2012-01-06 08:28:03 PST
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/83b039581185

Note You need to log in before you can comment on or make changes to this bug.