Last Comment Bug 714580 - JS_ASSERT_IF prints extra parens on failure
: JS_ASSERT_IF prints extra parens on failure
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla12
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks: 712129
  Show dependency treegraph
 
Reported: 2012-01-01 23:18 PST by Jesse Ruderman
Modified: 2012-01-03 04:02 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (810 bytes, patch)
2012-01-02 02:26 PST, :Ms2ger
jwalden+bmo: review+
Details | Diff | Review

Description Jesse Ruderman 2012-01-01 23:18:08 PST
Due to the patch in bug 712129, the failure in bug 709954 changed from

Assertion failure: !cx->isExceptionPending(), at js/src/jscntxtinlines.h:314

to

Assertion failure: (!cx->isExceptionPending()), at js/src/jscntxtinlines.h:314
Comment 1 Gary Kwong [:gkw] [:nth10sd] 2012-01-01 23:44:23 PST
I think I noticed it when reducing / bisecting bug 713944 too, which changed from:

Assertion failure: shape->writable(),

to:

Assertion failure: (shape->writable()),
Comment 2 :Ms2ger 2012-01-02 02:26:45 PST
Created attachment 585263 [details] [diff] [review]
Patch v1

How about this?
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-02 12:50:49 PST
Comment on attachment 585263 [details] [diff] [review]
Patch v1

Review of attachment 585263 [details] [diff] [review]:
-----------------------------------------------------------------

Stupid macros.
Comment 4 :Ms2ger 2012-01-03 04:02:40 PST
https://hg.mozilla.org/mozilla-central/rev/f301341f2e02

(In reply to Jeff Walden (remove +bmo to email) from comment #3)
> Stupid macros.

Indeed.

Note You need to log in before you can comment on or make changes to this bug.