Loading message causes Assertion in basic_nsAReadableString<unsigned short>::First()

VERIFIED DUPLICATE of bug 71399

Status

MailNews Core
MIME
VERIFIED DUPLICATE of bug 71399
17 years ago
10 years ago

People

(Reporter: kinmoz, Assigned: harishd)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
With my 03/09/01 Win32 Debug Mozilla build, using IMAP mail ...

I get an assertion in basic_nsAReadableString<unsigned short>::First() when 
clicking on the mail message, attatched to this bug, in the subject pane. Here's 
what the assertion is:

    NS_ASSERTION(Length()>0, "|First()| on an empty string");

I'm assigning it first to mail because, I can't seem to repro the problem when 
cutting out the html portion of the message and displaying it in the browser, so 
perhaps there is some mail/mime parsing code that is triggering this bug in the 
HTML parser?

Here's the full stack trace to the assertion:


NTDLL! 77f762e8()
nsDebug::Assertion(const char * 0x01c06c04 
??_C@_0BN@COJA@?$HMFirst?$CI?$CJ?$HM?5on?5an?5empty?5string?$AA@, const char * 
0x01c06c28 ??_C@_0L@LKAA@Length?$CI?$CJ?$DO0?$AA@, const char * 0x01c06bd4 
??_C@_0CH@IHJC@?4?4?2?4?4?2dist?2include?2nsAReadableSt@, int 630) line 254 + 13 
bytes
basic_nsAReadableString<unsigned short>::First() line 630 + 41 bytes
nsHTMLTokenizer::ConsumeAttributes(unsigned short 61, CStartToken * 0x0a4d22a0, 
nsScanner & {...}) line 583 + 8 bytes
nsHTMLTokenizer::ConsumeStartTag(unsigned short 61, CToken * & 0x0a4d22a0, 
nsScanner & {...}, int & 0) line 692 + 30 bytes
nsHTMLTokenizer::ConsumeTag(unsigned short 116, CToken * & 0x0a4d22a0, nsScanner 
& {...}, int & 0) line 538 + 28 bytes
nsHTMLTokenizer::ConsumeToken(nsScanner & {...}, int & 0) line 453 + 28 bytes
nsParser::Tokenize(int 0) line 2467 + 28 bytes
nsParser::ResumeParse(int 1, int 0) line 1908 + 12 bytes
nsParser::OnDataAvailable(nsParser * const 0x03d77e28, nsIRequest * 0x03d6dc70, 
nsISupports * 0x03d6de14, nsIInputStream * 0x03d71390, unsigned int 0, unsigned 
int 3803) line 2358 + 19 bytes
nsDocumentOpenInfo::OnDataAvailable(nsDocumentOpenInfo * const 0x03d71e70, 
nsIRequest * 0x03d6dc70, nsISupports * 0x03d6de14, nsIInputStream * 0x03d71390, 
unsigned int 0, unsigned int 3803) line 260 + 46 bytes
nsMimeBaseEmitter::Complete(nsMimeBaseEmitter * const 0x03d714e0) line 869 + 47 
bytes
nsStreamConverter::OnStopRequest(nsStreamConverter * const 0x03d71dc0, 
nsIRequest * 0x03d6dc70, nsISupports * 0x00000000, unsigned int 0, const 
unsigned short * 0x100b1c80 gCommonEmptyBuffer) line 995
nsDocumentOpenInfo::OnStopRequest(nsDocumentOpenInfo * const 0x03d6d970, 
nsIRequest * 0x03d6dc70, nsISupports * 0x00000000, unsigned int 0, const 
unsigned short * 0x100b1c80 gCommonEmptyBuffer) line 278
nsImapCacheStreamListener::OnStopRequest(nsImapCacheStreamListener * const 
0x03d6d650, nsIRequest * 0x03d6d8c0, nsISupports * 0x00000000, unsigned int 0, 
const unsigned short * 0x100b1c80 gCommonEmptyBuffer) line 6750 + 47 bytes
AsyncReadStreamAdaptor::OnStopRequest(AsyncReadStreamAdaptor * const 0x03d6d594, 
nsIRequest * 0x03d6d8c0, nsISupports * 0x00000000, unsigned int 0, const 
unsigned short * 0x100b1c80 gCommonEmptyBuffer) line 150 + 45 bytes
nsOnStopRequestEvent0::HandleEvent(nsOnStopRequestEvent0 * const 0x09ce3760) 
line 306 + 46 bytes
nsStreamListenerEvent0::HandlePLEvent(PLEvent * 0x09ce3770) line 98 + 12 bytes
PL_HandleEvent(PLEvent * 0x09ce3770) line 576 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00a83a50) line 509 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000e058e, unsigned int 49422, unsigned int 0, 
long 11024976) line 1054 + 9 bytes
USER32! 77e7124c()
00a
(Reporter)

Comment 1

17 years ago
Created attachment 27282 [details]
Mail Message that causes the assertion.
(Assignee)

Comment 2

17 years ago
This is fixed in my tree [ just didn't find the time to land :( ]. I'm taking 
the bug to my list.
Assignee: ducarroz → harishd
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 71399 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified as dup, dup has been fixed on 3-12, please reopen if you still see this
with builds after 3-12.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.