GfxInfoCollector.h used in Thebes API depends on string internal api

RESOLVED FIXED in mozilla12

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: David Marteau, Assigned: David Marteau)

Tracking

Trunk
mozilla12
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 585264 [details] [diff] [review]
gfxInfoCollector.patch

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Compile external binary xpcom component linking with xul library and using Thebes api.



Actual results:

Compilation failed because gfx/thebes/gfxPlatform.h include GfxInfoCollector.h which require MOZILLA_INTERNAL_API by using explicit reference to nsPromiseFlatString.(which is only defined for MOZILLA_INTERNAL_API).



Expected results:

Compilation should have succeeded because Thebes is defined as an exportable api for use in external components.

The proposed patch replace the the const ref to nsPromiseFlatString with a const ref to nsString which is a base class of nsPromiseFlatString and is compatible with the typedef for PromiseFlatString defined in nsStringAPI.h .
(Assignee)

Updated

5 years ago
Attachment #585264 - Attachment is patch: true

Updated

5 years ago
Assignee: nobody → daim.project

Updated

5 years ago
Attachment #585264 - Flags: review?(roc)
Attachment #585264 - Flags: review?(roc) → review+

Updated

5 years ago
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/93d49e745ff7
Keywords: checkin-needed
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/93d49e745ff7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.