Closed Bug 714627 Opened 13 years ago Closed 13 years ago

crash nsDownload::UpdateDB

Categories

(Toolkit :: Downloads API, defect)

11 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla12
Tracking Status
firefox11 + verified
firefox12 + fixed

People

(Reporter: cbook, Assigned: mak)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [qa!])

Crash Data

noticed on crash stats -> Firefox 12.0a1 Crash Report [@ nsDownload::UpdateDB() ]

example crash-report - https://crash-stats.mozilla.com/report/index/d74e9a17-ef80-4dff-a5ee-33ee62120101

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsDownload::UpdateDB 	toolkit/components/downloads/nsDownloadManager.cpp:3041
1 	xul.dll 	js::Interpret 	js/src/jsinterp.cpp:5518
2 	xul.dll 	nsCOMArray_base::RemoveObject 	obj-firefox/xpcom/build/nsCOMArray.cpp:123
3 	xul.dll 	nsDownload::Finalize 	toolkit/components/downloads/nsDownloadManager.cpp:2741
4 	xul.dll 	nsDownload::SetState 	toolkit/components/downloads/nsDownloadManager.cpp:2339
5 	nspr4.dll 	PR_GetCurrentThread 	nsprpub/pr/src/threads/prcthr.c:174
6 	xul.dll 	LiteralImpl::QueryInterface 	rdf/base/src/nsRDFService.cpp:511
7 	xul.dll 	XPCConvert::JSObject2NativeInterface 	js/xpconnect/src/XPCConvert.cpp:1272
8 	mozutils.dll 	choose_arena 	memory/jemalloc/jemalloc.c:2972
9 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.cpp:625
10 	xul.dll 	InMemoryDataSource::HasAssertion 	rdf/base/src/nsInMemoryDataSource.cpp:1160
11 	xul.dll 	XPCConvert::JSData2Native 	js/xpconnect/src/XPCConvert.cpp:516
12 	xul.dll 	RDFXMLDataSourceImpl::HasAssertion 	rdf/base/src/nsRDFXMLDataSource.cpp:251
13 	nspr4.dll 	PR_GetCurrentThread 	nsprpub/pr/src/threads/prcthr.c:174
14 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke_asm_x86_64.asm:90
15 	xul.dll 	nsTextFrame::PaintText 	layout/generic/nsTextFrameThebes.cpp:5420
16 	xul.dll 	nsRefPtr<ID3D10Texture2D>::nsRefPtr<ID3D10Texture2D> 	obj-firefox/dist/include/nsAutoPtr.h:923
17 	xul.dll 	nsDownload::FailDownload 	toolkit/components/downloads/nsDownloadManager.cpp:3090
18 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6306
19 	xul.dll 	JS_ValueToECMAUint32 	js/src/jsapi.cpp:546
20 	mozalloc.dll 	moz_xmalloc 	memory/mozalloc/mozalloc.cpp:103
21 	xul.dll 	nsDownload::OnStatusChange 	toolkit/components/downloads/nsDownloadManager.cpp:2503
22 	xul.dll 	XPCConvert::JSData2Native 	js/xpconnect/src/XPCConvert.cpp:729
23 	xul.dll 	nsDownloadProxy::OnStatusChange 	toolkit/components/downloads/nsDownloadProxy.h:122
24 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke_asm_x86_64.asm:90
25 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke_asm_x86_64.asm:129
26 	xul.dll 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1559
It's #12 top crasher in 11.0a2 and #47 in 12.0a1.

It first appeared in 11.0a1/20111119. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=447556784745&tochange=78c682982a80
It might be caused by bug 700544.

All stacks in x86 builds look like:
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsDownload::UpdateDB 	toolkit/components/downloads/nsDownloadManager.cpp:3041
1 	xul.dll 	nsLocalFile::Release 	xpcom/io/nsLocalFileWin.cpp:726
2 	xul.dll 	nsDownload::SetState 	toolkit/components/downloads/nsDownloadManager.cpp:2339

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsDownload%3A%3AUpdateDB%28%29
Blocks: 700544
Keywords: regression, topcrash
Hardware: x86 → All
Version: 12 Branch → 11 Branch
No, bug 700544 has nothing to do with the download database.
No longer blocks: 700544
Is the regreange verified? I don't see anything interesting in it.

Are you sure the first crash is in 11.0a1/20111119 and not in 11.0a1/20111219, if so it may just have the same cause as bug 713140.
and indeed the most recent crash I see is before Bug 713172 landed... we should just backport that.
Blocks: 711536
Depends on: 713172
I think 20 was the merge day, and maybe we got different nightlies?
For example ftp://ftp.mozilla.org/pub/firefox/nightly/2011-12-20-11-28-24-mozilla-central/firefox-12.0a1.en-US.linux-i686.txt would give a slightly larger bracket, that exactly includes bug 711536.
with the backout done in bug 713172 (https://bugzilla.mozilla.org/show_bug.cgi?id=713172#c34) this should slowly disappear from the stats. Please confirm.
(In reply to Marco Bonardo [:mak] from comment #7)
> with the backout done in bug 713172
> (https://bugzilla.mozilla.org/show_bug.cgi?id=713172#c34) this should slowly
> disappear from the stats. Please confirm.

Scoobidiver/Kairo - can you confirm that the backout in bug 713172 did in fact fix this top crasher?

If so, and this is still a top crasher for FF11, we should consider uplifting to Firefox 11 for beta 3 tomorrow.
Assignee: nobody → mak77
(In reply to Alex Keybl [:akeybl] from comment #8)
> Scoobidiver/Kairo - can you confirm that the backout in bug 713172 did in
> fact fix this top crasher?
The latest crashes happened in 12.0a1/20120112 and 11.0a2/20120120. bug 713172 has been fixed by the backout from Aurora 11 of bug 711536 on Jan 20.
So it's fixed by bug 713172 in 11.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
Scoobidiver, this implies that it's already fixed in beta, right?
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #10)
> Scoobidiver, this implies that it's already fixed in beta, right?

the cause has been backed out in Aurora 11, so the crash should not appear in beta.
Whiteboard: [qa+]
As visible here https://crash-stats.mozilla.com/report/list?query_search=signature&query_type=contains&reason_type=contains&range_value=4&range_unit=weeks&hang_type=any&process_type=any&signature=nsDownload%3A%3AUpdateDB%28%29 this crash reproduced last on Firefox 10.0.2 and on Firefox 11.0 beta 2 (buildID: 20120208012847). 

Was this issue supposed to be fixed in Firefox 11.0 beta 2? Should it be reopened, or can I close it considering that it has not reproduced on more recent builds?
Given that there are no incidents of this crashing on anything newer than 11.0b2 in the last 2 weeks, I think this can be marked verified.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.