Last Comment Bug 714633 - Release message manager related data structures more aggressively
: Release message manager related data structures more aggressively
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: 12 Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (high review load, please consider other reviewers)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-02 08:13 PST by Olli Pettay [:smaug] (high review load, please consider other reviewers)
Modified: 2012-01-07 11:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (7.54 KB, patch)
2012-01-02 08:13 PST, Olli Pettay [:smaug] (high review load, please consider other reviewers)
jst: review+
Details | Diff | Review
additional patch (3.44 KB, patch)
2012-01-06 11:03 PST, Olli Pettay [:smaug] (high review load, please consider other reviewers)
jst: review+
Details | Diff | Review

Description Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-01-02 08:13:44 PST
Created attachment 585288 [details] [diff] [review]
patch

This is part of my reduce-CC-times effort.
Comment 1 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-01-06 11:03:14 PST
Created attachment 586486 [details] [diff] [review]
additional patch

Silly me, I should read my own code better.

The JSContext swap is actually missing there even now, but it wasn't
causing real problems since mContext was set to null in Disconnect
and that just makes MM to use the implicit context or SafeCx.

RemoveFromParent() is added to keep the old behavior for tab swapping case.

https://tbpl.mozilla.org/?tree=Try&rev=ed99f63154c6
Comment 2 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-01-07 11:33:34 PST
https://hg.mozilla.org/mozilla-central/rev/39a83f2080dc
https://hg.mozilla.org/mozilla-central/rev/4052f4936e1c

Note You need to log in before you can comment on or make changes to this bug.