Last Comment Bug 714646 - jsgc.cpp fails to compile on Win64 GCC
: jsgc.cpp fails to compile on Win64 GCC
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Jacek Caban
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-02 09:27 PST by Jacek Caban
Modified: 2012-01-09 15:08 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (1.21 KB, patch)
2012-01-02 09:27 PST, Jacek Caban
igor: review+
Details | Diff | Splinter Review

Description Jacek Caban 2012-01-02 09:27:09 PST
Created attachment 585294 [details] [diff] [review]
fix v1.0

It fails because of cast from pointer to long, which loses precision on win64 and is an error by default on GCC. I've changed the code to use %p in JS_snprintf format, so that we don't need to cast anything.
Comment 1 Igor Bukanov 2012-01-06 07:37:17 PST
Comment on attachment 585294 [details] [diff] [review]
fix v1.0

Review of attachment 585294 [details] [diff] [review]:
-----------------------------------------------------------------

Nice trick of using %p :)
Comment 2 Jacek Caban 2012-01-09 07:01:44 PST
Thanks for review, pushed to m-i:

https://hg.mozilla.org/integration/mozilla-inbound/rev/8abe69741c4f
Comment 3 Ed Morley [:emorley] 2012-01-09 15:08:35 PST
https://hg.mozilla.org/mozilla-central/rev/8abe69741c4f

Note You need to log in before you can comment on or make changes to this bug.