Closed Bug 714699 Opened 9 years ago Closed 8 years ago

shouldProcess is never called

Categories

(Core :: DOM: Navigation, defect)

9 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 380556

People

(Reporter: twindnt, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

I wrote a content-policy add-on in Javascript.


Actual results:

shouldProcess was never called.


Expected results:

shouldProcess should have been called.
Component: XPCOM → Document Navigation
QA Contact: xpcom → docshell
Attachment #585348 - Attachment mime type: text/plain → application/zip
It's called for <object> once the type and such is known, and called for image documents.  That is, in the places where ShouldLoad did not have the information ShouldProcess has...

There are other existing bugs on calling it in other situations; depending on what exactly you were trying to do with it this is likely to be a duplicate of one of those.
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380556
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.