Update dialog not shown if Fennec hasn't been run for a longer time

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P4
major
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

11 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 affected, firefox12 affected, firefox13 affected, firefox14 affected, firefox15 affected, blocking-fennec1.0 -)

Details

(Whiteboard: [Updater])

(Reporter)

Description

6 years ago
Fennec 12.0a1  (2012-01-01)

When Fennec hasn't been run for a while and the Android notification bar offers an update, Fennec gets started but no update dialog appears. I have to manually check for updates again in "about:" to be able to upgrade.

Whatever state Firefox is in we should not fail in presenting the update dialog to the user. It makes it hard for normal users to find updates for their browser.

Updated

6 years ago
Hardware: x86 → ARM

Updated

6 years ago
status-firefox11: --- → affected
status-firefox12: --- → affected

Updated

6 years ago
Priority: -- → P4
Duplicate of this bug: 721808
I'll note this appears to happen in most cases where the system has shut down fennec (probably to reclaim ram).  Fennec reloads the last page loaded (usually into a new tab, leading to an ever-increasing number of tabs).
Duplicate of this bug: 736684

Comment 4

6 years ago
If we do end up shipping any builds as web downloads that update over AUS, QA has flagged this bug as a specific concern. Nominating for blocking-fennec1.0.
blocking-fennec1.0: --- → ?
(Reporter)

Updated

6 years ago
status-firefox13: --- → affected
status-firefox14: --- → affected
status-firefox15: --- → affected
minusing this for Fennec-1.0 important if we ship smaller locales as a manual download
blocking-fennec1.0: ? → -
Duplicate of this bug: 757021

Updated

6 years ago
Duplicate of this bug: 753381
Duplicate of this bug: 758105
Duplicate of this bug: 758771

Updated

5 years ago
Depends on: 786380

Updated

5 years ago
Whiteboard: [Updater]
Updater changed a lot; it now works better. Re-open if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.