some of the tar (tar.gz) after downloading with firefox being corrupted (which with other browser like Opera , IE , Chrome this not happens) (attached file)

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: pooya, Unassigned)

Tracking

9 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.37 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 585413 [details]
daemon_camup-0.1.tar.gz

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

In win32 , with firefox 9.1 , try to download one of the tar.gz (files) in the bellow host,
after downloading with firefox , and with winrar (7zip) the archive file shows corrupted.
but with other browser (like Internet Explorer , Opera , Chrome) when i try these tar (tar.gz) , the archive file rightly could be downloaded.
P.S : this problem not happened with all tar (tar.gz) files and firefox , with some of them happened . ( i mean , with other sources, except the link  bellow, in some other web pages , when with firefox tried to download tar files , same problem happened 


Actual results:

Please choose one of the tar files and download it with firefox 9.1 , in your win32 :
http://a1240200.websitehostfree.com/DGS/ALL-ADDONS/
After it's downloaded completely , if u want to extract it with winrar (7zip ...) the file which is downloaded by firefox is corrupted...


Expected results:

But if u download one of the tar.gz files with other browser like (internet explorer , Opera , Chrome... the same file could be extracted fine .
(Reporter)

Comment 1

7 years ago
I attached the file , For u in this ticket .
So once try with Firefox , after downloading with winrar try to extract it . u would see the file is corrupted by firefox
Then with other browser (like Internet Explorer) try to get the file , and u would see u could extract it with Winrar
Regards.
(Reporter)

Updated

7 years ago
Severity: normal → critical
Summary: some of the tar (tar.gz) after downloading with firefox being corrupted (which with other browser like Opera , IE , Chrome this not happens) → some of the tar (tar.gz) after downloading with firefox being corrupted (which with other browser like Opera , IE , Chrome this not happens) (attached file)
Component: Extension Compatibility → Untriaged
QA Contact: extension.compatibility → untriaged

Comment 2

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

WFM with latest nightly
(Reporter)

Comment 3

7 years ago
1. yes , The problem, Happened in safe mode too
2. With new empty profile happens too
btw: this problem has not happened only with the one above link , there are more website , but since one is russian forum (and for downloding the attachment , u need to subscribe , guess it's bit hard for u to try with other links...
P.S :But anyway i attached one tar.gz file in this ticket , which u could do experiment on it , i mean with firefox (7, 8 , 9 , 10 beta ) if u get the attached file , after downloading the file is corrupted (by firefox) , but with other browser this problem not happend with the same file (link)
(Reporter)

Comment 4

7 years ago
i have just tried with lated nightly (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-12.0a1.en-US.win32.installer.exe

This problem happens too with this version , and some of the tar or tar.gz files
Regards.

Comment 5

7 years ago
I am able to open the file you attached using 7-zip with all versions of Firefox I tested. 

How do you know these files are corrupt? What zip program are you running? You may want to try 7-zip from www.7-zip.org.
(Reporter)

Comment 6

7 years ago
Well , i tried with winrar .
Now , i try with 7zip , confirm u (i mean after downloading with firefox , 7zip could extract it , guess 7zip automatically make repair when user extract ...)

Anyway still the problem is concern about firefox (not winrar problem) because when with other browser like chrome , IE , i download the same link , even with winrar could extract it well here . but when use firefox + winrar -> error log shows the file is corrupted.
would u please try once with winrar ( i am sure , u could reporduce the problem with firefox and winrar .

Thanks in advance
(Reporter)

Comment 7

7 years ago
so would u please try with winrar and firefox , the attached file in this ticket ->reproduce bug (file is corrupted)
Then with Other browser + winrar -> u would see archive file will be fine
Regards.
Are you still seeing this problem with the current version of Firefox? Thanks!
Flags: needinfo?(pooyair)
I just reproduced all the steps and it seems to be working properly, maybe we can close this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(pooyair)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.