IndexedDB: can't open any database after deleting one (with Aurora 11.0a2)

RESOLVED DUPLICATE of bug 714921

Status

()

RESOLVED DUPLICATE of bug 714921
7 years ago
7 years ago

People

(Reporter: maxime.rety, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 585421 [details]
delete-reopen.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

I tried this little javascript sequence :

* open an IndexedDB database
* close the connection to the database as soon as it is open
* delete the database
* open the same database again (or another database, nevermind)

(see attached file)


Actual results:

When re-opening the database, onerror handler is called with an error not providing any useful information.

Then, if you try to open any IndexedDB database, onerror handler will be called, and you won't get more information on the problem.

IndexedDB is permanently broken.


Expected results:

It should not fire an error at all, or the error should carry information on the problem's cause.

The code in the attached file is working well with Firefox beta 10.0b2, but is broken with Firefox Aurora 11.0a2

Am I doing something wrong or is there a bug ?
We broke it, but it'll be fixed soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 714921
Component: General → DOM: IndexedDB
Version: 11 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.